I am trying to install Sybase ASE 12.5.4 64 bit. I know the machine has a 64 bit processor It is giving me an error during install saying: "error while loading shared libraries: libaio.s0.1"

I run the command:
rpm -q --qf '%{NAME}-%{VERSION}-%{RELEASE} (%{ARCH})\n' libaio

Which returns:
libaio-0.3.105-2 (i386)

I found a src rpm for libaio-0.3.102. I followed the steps to install which included using make. It appeared to install without error. But when I run the rpm -q command again I still only see the i386 version installed.

Not really sure where to go from here. Ideally I would like to find a regular rpm of libaio x86_64 for RHEL 4.8. If I were to find one would I upgrade the package that is already there? Would I remove and install the new one. Or would I install and two separate version of the library?

  • I solved my problem by creating a symbolic link from the libaio that I compiled from source to usr/lib64/libaio.so.1. – Jon Jan 14 '10 at 19:26

Are you sure you're actually running 64 bit Linux? Try checking uname -m.

If you have libaio-0.3.105-2 (i386), don't use -0.3.102 (x86_64). Grab the proper RPM from a CentOS mirror if you don't have access to up2date.

The libraries can coexist.

Edit: SRPMs are usually rpmbuild -bb. make isn't typically required. Building the SRPM will give you a RPM in a subdirectory of /root (by default) which you must manually install.

  • Thank you for your reply uname -m returns x86_64 I found that out after looking at /usr/lib and usr/lib64 – Jon Jan 14 '10 at 19:25
  • Go grab the RPM from here and install it as usual with rpm -Uvh. – phresus Jan 15 '10 at 12:39

or install package 'libaio.x86_64' which is on install cd. cd can be downloaded from redhat. you can have both versions installed (i386 as well as x86_64)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy