0

On my windows server 2016 I userd disk2vhd for backups, but for some reason last backups that disk2vhd created in last time was invalid.
Disks works ok and whole system too.
So I want to make backups with VSS, I created vss snapshot mounted it as disk S: and tried to copy files from it via
xcopy /E /H /R
robocopy /xj /E /B

But in both ways I got "Access is Denied" on some files, sometime system files, sometime user files.
I am using cmd as administrator.
Admin approval mode disabled in group policy.
But I am still getting "Access is Denied" error

How I can backup full disk without getting Access is Denied error ?
Maybe someone can advice me easier way to do it.

  • Just out of interest what do you copy the VHD's to to take them off-site? – Chopper3 Aug 1 at 15:40
  • 1
    @Chopper3 to save disk backup in another location. – Sergey92zp Aug 1 at 15:58
1

I still don't know why my cmd can't get access.

Workaround that I found is use any other app like total commander, Salamander, 7zipFM,Cygwin with elevated rights and it works ok.

UPD: Also if you want even more ritghts you can use PsTools

psexec.exe -s -i cmd.exe

and you'll get Local SYSTEM user account rights.

BTW: on symlinks you'll still get Acess is Denied.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.