0

We are currently running a Fedora 28 server. Due to the server being restarting multiple times, FirewallD has stopped working. Based on the error messages presented when we run the command systemctl status firewalld, it appears as though the ABRT daemon has failed.

How am I able to resolve this problem?

[root@ashishnkbaba ~]# systemctl status firewalld
- firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2020-08-08 22:39:32 IST; 6min ago
     Docs: man:firewalld(1)
  Process: 2597 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=exited, status=1/FAILURE)
 Main PID: 2597 (code=exited, status=1/FAILURE)

Aug 08 22:39:32 ashishnkbaba systemd[1]: Starting firewalld - dynamic firewall daemon...
Aug 08 22:39:32 ashishnkbaba python3[2597]: detected unhandled Python exception in '/usr/sbin/firewalld'
Aug 08 22:39:32 ashishnkbaba python3[2597]: can't communicate with ABRT daemon, is it running? [Errno 111] Connection refused
Aug 08 22:39:32 ashishnkbaba python3[2597]: error sending data to ABRT daemon: 
Aug 08 22:39:32 ashishnkbaba systemd[1]: firewalld.service: Main process exited, code=exited, status=1/FAILURE
Aug 08 22:39:32 ashishnkbaba systemd[1]: firewalld.service: Failed with result 'exit-code'.
Aug 08 22:39:32 ashishnkbaba systemd[1]: Failed to start firewalld - dynamic firewall daemon.
[root@ashishnkbaba ~]# systemctl restart firewalld
Job for firewalld.service failed because the control process exited with error code.
See "systemctl status firewalld.service" and "journalctl -xe" for details.
4
  • Please update to a supported release. Fedora 28 is past end of life. – Michael Hampton Aug 8 '20 at 17:32
  • is there any alternative as i knew life is already expired @MichaelHampton – Ashish Prajapati Aug 8 '20 at 17:39
  • As @MichaelHampton advised, you need to upgrade to a supported release. Server Fault is for questions about managing information technology systems in a business environment. Unless the system is completely offline it poses a security risk, and as such isn't supported here. You will need to research ways to upgrade the system. – Christopher H Aug 17 '20 at 5:55
  • thanks for your prompt response @ChristopherH i've added to the lastest one and issue got rectified. – Ashish Prajapati Aug 18 '20 at 19:17
0

Your server is running an outdated and unsupported version. Please update the OS version, which will resolve it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.