So after my website ( running on a Rackspace 2GB ram centos 7 instance) went down twice this week I went through the logs and seems the culprit are bots ( search engine and others.. )

The bots seem legitimate as the site has undergone major changes, I'm assuming this triggers the bots to crawl more..

After doing some reading it seems I should have some settings in my httpd.conf file in regards to prefork, I don't have any although I've confirmed it's installed on the server...

The errors I'm seeing are

[mpm_prefork:info] [pid 31961] AH00162: server seems busy, (you may need to increase StartServers, or Min/MaxSpareServers), spawning 8 children, there are 0 idle, and 18 total children

surrounded by hundreds of these type entries

[Sat Aug 08 15:33:30.066982 2020] [proxy:debug] [pid 11277] proxy_util.c(1936): AH00931: initialized single connection worker in child 11277 for (*)

[Sat Aug 08 15:33:31.070400 2020] [proxy:debug] [pid 11278] proxy_util.c(1843): AH00925: initializing worker proxy:reverse shared

[Sat Aug 08 15:33:31.070477 2020] [proxy:debug] [pid 11278] proxy_util.c(1885): AH00927: initializing worker proxy:reverse local

Even if the bots slow down I still feel this should be set as good practice no?

Perhaps something like this should work ( from this site)

<IfModule prefork.c>
   StartServers        5
   MinSpareServers     5
   MaxSpareServers     10
   MaxClients          150
   MaxRequestsPerChild 3000

Any suggestions are appreciated.

  • Stop using mpm_prefork. It dates back to the 1990s and doesn't scale today. Use mpm_event instead. – Michael Hampton Aug 10 at 16:37
  • Thanks and I'm not using prefork , at least I think Im not, I don't see its settings anywhere in the httpd config file – Nick Aug 11 at 13:32
  • You posted the prefork settings in your question! And the log entries show that you are using prefork. – Michael Hampton Aug 11 at 16:46
  • I was asking if I should use those settings... I copied those settings from the linked site – Nick Aug 12 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.