2

Environment: AWS / Microsoft Windows Server 2019 VM

A few .NET applications are running on a VM (as windows services), which make various HTTP requests. One of these is also using MQTT (via MQTTnet) to relay events from an external service to a different HTTP API.

Everything will work as expected for a few days, until finally HTTP requests from the applications start timing out.

Windows Event Viewer shows the following error every few minutes: "The WinHTTP Web Proxy Auto-Discovery Service service terminated with the following service-specific error: The endpoint mapper database entry could not be created."

At this point, seemingly any Win32/.NET application will fail to execute an HTTP request, including IE, etc -- but not CURL. Likewise, other network connectivity and protocols seem fine. I'm assuming this would be due to an issue with WinHttp (or other low level Win32 HTTP services)? I've spent some time researching the Web Proxy Auto-Discovery service and trying to understand why it would suddenly start failing (and if it's the cause or just an effect), but I haven't found anything online.

I haven't found corrective action (restarting services, resetting things with netsh, etc) that will fix this condition. Only a full restart of windows seems to solve it. At which point the WinHTTP Web Proxy Auto-Discovery Service is happy again, http requests work again, etc.

I'm struggling to even find where to begin to troubleshoot this. Text

5
  • Have you tried to install the latest Windows updates? Oct 6 '20 at 9:38
  • Did you solve this issue? The you try the answer below?
    – Action Dan
    Dec 15 '20 at 1:15
  • Hi, I'm getting the same problem. Did someone find an actual solution around this? Or was it maybe fixed with an Update? Mar 8 at 21:54
  • I tried the single answer to this problem and it did not work. We are simply restarting the servers when this happens, and we know it happens because we have a script try to do a http call from powershell every few hours and it emails us when that fails.
    – Action Dan
    Mar 20 at 7:42
  • I have not found a solution to this problem. Disabling the IP helper service did not change anything. Upgrading the AMI also did not seem to solve it. Mar 22 at 3:58
0

I had the same problem. I had disabled the services "WinHttpAutoProxySvc" and "iphlpsvc" in the instances that I had the problem . The service "iphlpsvc" depends on "WinHttpAutoProxySvc" and provides connectivity IPv6 over IPv4 (6to4). I haven't detected any problem with this action since last month and up to now.

2
  • Hi did this problem resurface? Can you let me know why you looked to those services in particular?
    – Action Dan
    Dec 15 '20 at 1:16
  • This didn't solve the issue for me. Mar 22 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.