0

This is my first time deploy wordpress on Google Cloud Platfrom, My website having error 522 after uploaded some jpg image to wordpress.
I failed to connect to ssh, and telnet external & internal ip both return 'connection timeout'.

project@cloudshell:~ (project)$ gcloud -v
Google Cloud SDK 307.0.0
alpha 2020.08.21
app-engine-go 1.9.71
app-engine-java 1.9.82
app-engine-python 1.9.91
app-engine-python-extras 1.9.91
beta 2020.08.21
bigtable
bq 2.0.59
cbt 0.9.0
cloud-build-local 0.5.0
cloud-datastore-emulator 2.1.0
core 2020.08.21
datalab 20190610
gsutil 4.53
kind 0.7.0
kubectl 1.15.11
minikube 1.12.3
pubsub-emulator 0.1.0
skaffold 1.13.1
project@cloudshell:~ (project)$ service ssh status
[ ok ] sshd is running.
project@cloudshell:~ (project)$
project@cloudshell:~ (project)$ service --status-all
 [ - ]  apparmor
 [ + ]  cgroupfs-mount
 [ - ]  cron
 [ - ]  dbus
 [ + ]  docker
 [ ? ]  hwclock.sh
 [ ? ]  kmod
 [ ? ]  lxc
 [ ? ]  lxc-net
 [ - ]  postgresql
 [ - ]  procps
 [ + ]  rsyslog
 [ + ]  ssh
 [ - ]  sudo
 [ - ]  supervisor
 [ + ]  udev
 [ - ]  x11-common

I tried restart the vm instances multiple times and increase the machine memory but still no luck. Can anyone tell me how to fix this problem or how to debug?

*UPDATE
I just found when i type systemctl in google shell, it return System has not been booted with systemd as init system (PID 1). Can't operate. Failed to connect to bus: Host is down, does it matters? I'm new to this

6
  • Did you use the correct IP address? Sep 2 '20 at 2:18
  • @MichaelHampton u mean the external ip? Im sure i using the correct one.
    – Ashley
    Sep 2 '20 at 2:28
  • Did you check to ensure that it did not change? Sep 2 '20 at 2:29
  • @MichaelHampton it changed after i reboot the instances, i update all the dns setting on gcp and cloudflare
    – Ashley
    Sep 2 '20 at 2:32
  • Hmm. You should consider making your external IP address persistent. Sep 2 '20 at 2:33
1

-- Connection via Cloud Identity-Aware Proxy Failed

-- Code: 4003

-- Reason: failed to connect to backend

Please check official documentation on Failed to connect to backend from troubleshooting SSH.

These errors occur when you try to use SSH to connect to a VM that doesn't have a public IP address and for which you haven't configured Identity-Aware Proxy on port 22.

To resolve this issue Create a firewall rule on port 22 that allows ingress traffic from Identity-Aware Proxy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.