-1

I have a RaspberryPi at home running PiVPN (OpenVPN) and a VPS connected to the VPN as client. VPS works fine as VPN client, I see network devices, I can ping to Internet, etc.

I use this VPS as video surveillance system (Shinobi software) which connects to my home network cameras and it has a web panel to manage the system running on port 8080.

So, the problem is that if I access to my VPS web admin url (http://VPS-PUBLIC-IP:8080) in my home network/VPN I can access to the web panel with no problem, but if I try it outside my network, for example with my mobile 4G network, the port is closed.

I tried to open port 8080 in my router for RaspberryPi IP (192.168.1.8) and VPS client IP when is connected to the VPN (10.8.0.2) but I had the same result.

As you can see, I am not an expert in Linux networks.

Regards.

  • Which Linux Distro you use for vps? You have to open the vps Firewall on port 8080 for public ip – Wulf Sep 2 at 7:00
  • Btw 8080 is not http (that's 80). Incoming connections to a NATed address are usually not defined (=closed). Some port mapping of some sort has to be created between either the router or the host that maps an incoming port to your local 192.168 address. – e2-e4 Sep 2 at 7:02
  • @e2-e4 No - thats not the case. 8080 is alternativ http for 80 – Wulf Sep 2 at 7:05
  • @Wulf by convention the http port is 80, of course 8080 can answer the http protocol ... – e2-e4 Sep 2 at 7:06
  • @e2-e4 8080 Alternative port for HTTP. See also ports 80 and 8008. - en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers. You are right in that sense, that 80 is the http port – Wulf Sep 2 at 7:07
0

So you cannot connect to your RPi from the internet. Assuming the ports are open correctly, could you try connecting from the internet when your VPN service is down?

If it works when the VPN is not turned on, then you have the issue to route correctly traffic coming from your router back to your router, instead of through VPN.

here is the fix for this issue (to be applied when VPN is turned off) https://serverfault.com/a/918441/590398

It works for me, however, it is not retained for me after reboot.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.