0

I have a Virtual Machine from VirtualBox running Windows Server 2012 R2 Standard which is used for some development tasks. I wanted to install an SMTP server, so I can send emails from there, however, everytime I do so I get an error page which looks like this

image of error

I used this link https://docs.microsoft.com/en-gb/biztalk/install-and-config-guides/appendix-d-create-the-smtp-server#install-smtp-server to get information on how to install the STMP server.

After this failed the first time, I searched the internet a bit, and found a solution which said that if Windows Update is deactivated, then you have to manually provide the sources, however, I have Windows Update installed and it works, since it checked this morning for updates.

Anyhow, I still downloaded the .iso of Windows Server 2012 R2 from https://www.microsoft.com/de-de/evalcenter/evaluate-windows-server-2012-r2#evaluation_521 and tried two things

  1. Add the .iso via VirtualBox (Devices -> Optical Drives -> Choose a disk file...) so it was in the path D:\
  2. Extact the .iso in my machine to a folder so it was in the path C:\Downloads\Win10

I again went through the installer and clicked "Specify an alternate source path" on the Confirmation screen and tried both solutions

image of specify alternate source path

but it still didn't fulfill the installation and had the same error as in the image above, stating that the source files are missing.

But as you can see in the following screen, you can see that it should work

image of my mounted iso in explorer

Update 1

So what I then tried is to do this via PowerShell "Install-WindowsFeature -Name SMTP-Server -Source D:\sources\sxs" but this fails with

Install-WindowsFeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be downloaded.
Use the "source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f0906
At line:1 char:1
+ Install-WindowsFeature -Name SMTP-Server -Source D:\sources\sxs\
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
    Exception
    + FullyQualifiedErrorId : DISMAPI_Error__Cbs_Download_Failure,Microsoft.Windows.ServerManager.Commands.AddWindowsFeatureCommand

which is strange, since you can see that I'm using a source parameter. When I add /source it tells me that this parameter is not supported

I even tried it with Dism but when I use Dism.exe /online /Get-Features there is no listing of an SMTP Server and when I use Dism.exe /online /enable-feature /featurename:SMTP-Server /Source:D\sources\sxs /all it tells me that there is no feature named SMTP-Server

Update 2

I also followed this tutorial in here https://docs.microsoft.com/en-gb/windows-hardware/manufacture/desktop/configure-a-windows-repair-source#configure-group-policy-for-feature-on-demand to set my repair sources to be from Windows Update instead of WSUS but till the same error. :/

  • I have previously solved similar issues by mounting the ISO with the same drive letter as the original setup. You may need to dig into the registry to find this info. Alternately you could use SysInternals procmon to help discover where the setup is looking. – Jens Ehrich Sep 10 at 1:28
1

Try using DISM to restore the health of your OS Dism /Online /Cleanup-Image /RestoreHealth

If you get the missing sources error again, you can add /Source:c:\test\mount\windows if you mount a wim file with dism - make sure the wim matches your OS!

SMTP Server requires .NET 3.5, is that successfully installed? If not, try installing it alone first and see if the problem is the .NET install.

| improve this answer | |
  • Sadly, this also fails with error 0x80240021 which led me to a solution using Dism /Online /Cleanup-Image /StartComponentCleanup but after that, when I run command you tould me, I get 0x800f081f, but even after using Dism /Online /Cleanup-Image /Scanhealth before or even with supplying source /Source:wim:D\sources\install.wim:1 /LimitAccess it doesn't work. I have .NET 3.5 installed – Musterknabe Sep 14 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.