Suddenly, I cannot start services on my VPS(CentOS 7). For example,

service httpd start
Redirecting to /bin/systemctl start  httpd.service
Authorization not available. Check if polkit service is running or see debug message for more information.
Failed to start httpd.service: Connection timed out
See system logs and 'systemctl status httpd.service' for details.

This is probably because the domain name I used as the host name has expired. I do not know the logic behind the service command. I start httpd, why does it invoke polkit service? The polkit service is also dead and cannot be started. The "service polkit status -l" command shows a message:

Lost the name org.freedesktop.PolcyKit1 - exiting

How to solve the problem?

  • what does systemctl start httpd return?
    – Tom
    Sep 13, 2020 at 13:12

1 Answer 1


You need to use sudo

[user@localhost ~]$ sudo systemctl start httpd

or login as root

[root@localhost ~]# systemctl start httpd

in order to start and stop services.

  • I am also having this problem, however I still get the same error message even when as root. Do you have any suggestions?
    – rnoodle
    Feb 4, 2021 at 16:34
  • @rnoodle Click the Ask Question button. Feb 4, 2021 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.