1

I suspect some faulty RAM and wanted to test it with Memtest86. I'm using a bootable Ubuntu 20.04 USB stick and choose the "Memtest" option from the boot menu.

Unfortunately the test freezes after 5-6 sec.

I've tried this on 2 different systems and no luck. One is a brand new Ryzen 3900XT CPU with ASRock B550 Extreme4 Motherboard And the other is an Intel Xeon E-2176G CPU with Supermicro X11SCA-F motherboard.

The RAM is ECC RAM. I have 4 sticks and tried testing them 1 by 1 by physically removing them from the motherboard.

Same freezes.

I know there are some motherboards that have issues, so I tried the failsafe mode (press F1 on startup) and also tried the single CPU mode by entering config with letter "c" before start.

It appears there is now no way for me to test the RAM. Any other ideas?

4
  • Possibly all sticks are bad. Have you tried testing one together with a known-good DIMM?
    – Zac67
    Oct 12 '20 at 20:30
  • Also, have you tried the standalone memtest86 version?
    – Zac67
    Oct 17 '20 at 7:48
  • If you mean the version from memtest86.com, yes I have. No luck :(
    – Wouter
    Nov 4 '20 at 12:43
  • HCI Memtest has a free version and a paid version that can boot from USB itself. I had bad RAM once and HCI found it where memtest didn't.
    – Tim
    Feb 14 at 17:56
2

The most likely cause - LP #1876157: Memtest86+ in Ubuntu 20.04 doesn't work. So if the memtest you ran was from Ubuntu 20.04 images, try running memtest from Ubuntu 18.04 images.

Also, try single-threaded tests for further troubleshooting. But you already mention that there isn't any difference, so it might be the first reason.

Here's a List of Motherboards with issues when running MemTest86 in multi-CPU selection modes, which is mostly not much up to date with newer hardware. The user from this post guesses that problems with his two Supermicro models of X10SAE and X10SLH-F may have the same problem but it happens after a long testing time of 30+ hours.

Edit: I didn't mention this because it is obvious but still - check with different slots on the MB. Doesn't sound like an issue for you, since you already tried different systems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.