1

I am replacing some Windows Server 2008 R2 boxes with new Windows Server 2019 boxes. Both sets are mostly administered over RDP.

The new 2019 set kicks RDP sessions back to the login screen after a certain amount of time idle; I am not sure how long, but something between 10-30 minutes. When I'm working on many servers at once and switching between them, this gets very frustrating very quickly. The old 2008 R2 set does not do this.

I could not find any configuration difference between the two sets. I've tried the following via group policy settings on the new set:

  • Microsoft Network Server: Amount of idle time required before suspending session (600 minutes)
  • Interactive logon: Machine inactivity limit (86400 seconds)
  • Turn off the display (plugged in): (10 hours)

They successfully apply, but none of them helped. I checked screensaver settings too (grasping at straws), and screensavers appear to be disabled by default (which makes sense). I couldn't find anything else that might require login after idling.

Clearly I'm missing some setting. But where?

1

The relevant settings are:

Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Session Time Limits

  • End session when time limits are reached
  • Set time limit for active but idle Remote Desktop Services connections
  • Set time limit for active Remote Desktop Services connections
  • Set time limit for disconnected sessions

If there is a firewall between the client and the server, an keep-alive interval should be configured.

Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections

  • Configure keep-alive connection interval

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.