I'm running isc-dhcp-server (dhpcd) version 4.4.1 on ubuntu 20.04 with a subnet configured like so, which has been working just fine.

# /etc/dhcp/dhcpd.conf
subnet netmask {
  option routers;
  filename "pxelinux.0";
  allow bootp;
  allow booting;


I recently tried changing next-server to another IP and restarted the DHCP server, however when a PXE client issues a DHCP discover it responds with a DHCP offer that contains the old next-server IP

Could it be that the bootstrap protocol (bootp) information linked to a lease? No reference to next-server in /var/lib/dhcp/dhcpd.leases from what I can see at least.

For what it's worth I tried changing in another subnet and that works, but haven't been able to identify any differences in their configuration.

1 Answer 1


This turned out to be caused by class declarations being included inside one of the subnet declarations, when they're actually supposed to be globally defined. In turn this messed with the subnets that were defined, including the one in question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .