1

I'm trying to use rsync in a Cygwin terminal to sync some folders with my linux server. The problem is, the password prompt comes up ok but when I enter the password, it is echoed to the screen and then sits there. There is no rsync process running on the linux server. When I ctrl-c out of the client side of things, the password is entered as a command on the command line.

I've tried this with and without the command line options (aviz), with a --password-file option (complains needs an rsync daemon), with double colons (could not connect error for that one). No luck. I've used rsync thousands of times on linux systems, including several times with odd setups but not sure what the deal is here.

2

I found out that this is because it uses openssh from Windows than doesn't work well with cygwin. Try instal openssh on cygwin - it worked for me.

0

You may want to run rsync over ssh by specifying rsync -e ssh -avz <source> <destination>

Make sure that you have ssh client installed in Cygwin.

1
  • I'll give that a try but my understanding is that rsync is supposed to default to ssh with the correct source or target specification. I ended up doing things a different way. Oct 28 '20 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.