I recently did a fresh install of Ubuntu on my laptop (HP dv7, AMD Dual Core with 4 gigs RAM). I am working on installing my development environment and tools and one of the first things I was working on is getting MySQL installed.

The following was my configure statement with options:

./configure --prefix=/usr/local/mysql --with-big-tables --with-unix-socket-path=/usr/local/mysql/tmp/mysql.sock --with-named-curses-libs=/lib/libncurses.so.5.7

After I did the make;make install, I did the post configuration such as setting the root password and installing the mysqld daemon in its rightful place.

My issue is when I try to log in to mysql to start using it, the following shows what happens:

$ mysql -u root -p
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 5.1.42 Source distribution

Segmentation fault

I have searched Google extensively, I have searched through the mysql bugs database and I have yet to find anything that matches my issue.

Here is the contents of my my.cnf file, in case you want to see it:

$ cat /etc/my.cnf




I am really hoping that someone here can tell me what has gone wrong with my installation as I would really love to know. I welcome and look forward to all responses.

migrated from stackoverflow.com Jan 17 '10 at 14:29

This question came from our site for professional and enthusiast programmers.


Why not use apt-get to install a package of the mysql binary that has been tested with your distro?

  • I have used binary distributions on all my other systems and on this one I wanted to go through the painstaking process of installing everything from source and include all the options that I want and are relevant to my system. Granted, this is more specific to things like Apache and PHP's builds, but I just wanted to do it with MySQL as well. Call me a masochist. – numberwhun Jan 16 '10 at 2:55
  • Fair enough. Are you familiar with the 'ldd' command? Try running it to check the library dependencies of your server daemon. – AJ. Jan 16 '10 at 2:59
  • Ok, silly question. What should I run ldd on? In other words, how do I run it against the server daemon for mysql? I tried it against /etc/init.d/mysql and it says it isn't a dynamic executable. So, that's obviously the wrong thing to run it against. – numberwhun Jan 16 '10 at 3:27
  • Look in /usr/local/mysql/bin and you should see a file called 'mysqld'. That is the server binary. – AJ. Jan 16 '10 at 15:21
  • Ok, I ran it against the mysqld file from the source as it didn't exist with that name in the /usr/local/mysql/bin directory. When I ran the 'ldd mysqld' command, it gave me a list and I verified that all but one of the libraries listed was on the system. The one missing is 'linux-vdso.so.1'. Will that library cause this? Also, back to the mysqld binary list, should there be a 'mysqld' file in /usr/local/mysql/bin or just the mysqld_safe file? – numberwhun Jan 16 '10 at 17:16

Just to let everyone know, I decided to back out my build and install mysql via apt-get in Ubuntu. I was chatting with someone on the Ubuntu IRC and they highly recommended it. I want to thank AJ for his help as I did learn to use ldd for the first time, but in the end, installing it via apt-get seemed plausible as I wasn't doing anything truly out of the ordinary that was not covered by the binary installation.

Thanks again for the help!




try adding --disable-thread-safe-client to your compile time options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.