4

I have upgraded from Ubuntu 18.04.1 to Ubuntu 20.04.1 (forced release upgrade), then while installing php.7-4 it was necessary to also install libssl-dev, that gave the following unmet dependencies:

sudo apt install libssl-dev
The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.1 (= 1.1.1f-1ubuntu2) but 1.1.1g-1+ubuntu18.04.1+deb.sury.org+1 is to be installed
  • I have disable the repositories: ondrej and certbot. The remaining repositories are the default for focal fossa (20.04.1)

  • Clean up repository e.g (apt update --fix-missing)

But sill the same problem.

2 Answers 2

12

The issues is with the letter version of libssl1.1 (= 1.1.1f-1ubuntu2) that needs to be downgraded. It was simple to do it with synaptic instead of apt install as follows:

sudo aptitude install libssl-dev

he following NEW packages will be installed:
  libssl-dev{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1.582 kB of archives. After unpacking 8.005 kB will be used.
The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.1 (= 1.1.1f-1ubuntu2) but 1.1.1g-1+ubuntu18.04.1+deb.sury.org+1 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libssl-dev [Not Installed]                         



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Downgrade the following packages:                                                   
1)     libssl1.1 [1.1.1g-1+ubuntu18.04.1+deb.sury.org+1 (now) -> 1.1.1f-1ubuntu2 (focal)]



Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
  libssl1.1 
The following NEW packages will be installed:
  libssl-dev 
0 packages upgraded, 1 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 2.900 kB of archives. After unpacking 8.087 kB will be used.
Do you want to continue? [Y/n/?] Y

Basically don't accept the proposed solution and carry on the a package downgrade

2
  • This works. Thank you.
    – Hoang Tran
    Oct 2, 2020 at 11:35
  • Thank you! Tried it with synaptic, nothing worked except your solution. Strange thing is is that on an 20.04 ubuntu installation from last month it works out of the box. A fresh install from Ubuntu 20.04 I get this issue.
    – eddy147
    Aug 21, 2021 at 14:07
0

I just do this and worked for me :)

sudo apt-get install libssl1.1="1.1.1f-1ubuntu2"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.