0

Libvirt has stopped working altogether on any VM (windows or linux) on the qemu/kvm networt and has the following error each time I try to start something:

error: internal error: Failed to start QEMU binary /usr/bin/qemu-system-x86_64 for probing: qemu-system-x86_64: cannot create PID file: Failed to write pid file

If I try to create a new VM on the qemu/kvm network, I'm given:

Host does not support any virtualization options

However, running and starting VM's on a qemu/kvm user session network works fine. I have also been able to use the qemu/kvm network before without problems for a long time, and I'm unsure what's triggered it to stop working now.

I have tried starting the qemu-system-x86_64 binary from a terminal and that works fine too.

How can I resolve this error?

0

This was solved by a helpful someone on the libvirt mailing list. My /var partition was out of space, and that's why libvirt couldn't create any PID file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.