-1

I'm running Ubuntu 20 and have installed Pure-FTPd. When I SFTP on port 22 with FileZilla the log shows "We claim SSH-2.0 FileZilla ... Remote version SSH-2.0 OpenSSH..." On login with FileZilla, auth.log shows an ssh2 connection.

I'm confused about why I don't see something like "Welcome to Pure-FTPd [privsep] [TLS]". The service is running. I haven't read anywhere that we need to do anything to tell OpenSSH to hand over SFTP requests to another process. I'm guessing that something else needs to be set under /etc/ssh/sshd_config.d ?

It doesn't look like the PureFTPd service is processing these requests at all, with its own user db or other settings.

Thanks.

8
  • 2
    No, SFTP is not FTP over SSH. You don't need an FTP server here at all. Uninstall it. Oct 8 '20 at 22:42
  • Or if you really want to use FTP, you need to connect to FTP port 21 with FTP client. Oct 9 '20 at 6:22
  • @MichaelHampton I eliminated the incorrect/controversial comment about SFTP/SSH so that this question stays focused. Thanks. But your note about what I don't need is misplaced as well. There is nothing in the question about my reasoning for using FTP so your assessment has no basis.
    – TonyG
    Oct 10 '20 at 21:20
  • @MartinPrikryl if I just wanted insecure FTP rather than SFTP, I wouldn't be asking this question related to SSH. But thanks for your suggestion as well.
    – TonyG
    Oct 10 '20 at 21:20
  • 1
    Again, Pure-FTPD has nothing to do with SFTP. It does FTP, and maybe FTPS, but neither of those are what you claim to want. Uninstall it. Oct 10 '20 at 21:41
-2

SSHD runs on port 22 by default. There is no handing over, when a process is started and a port is allocated, that port belongs to that application until it stops running or is terminated.

You need to set a different port for sftp, or disable sshd.

To test this quickly, simply kill sshd and start ftpd.

ps -ef | grep sshd

kill -9

Where is the process id of the sshd process.

1
  • 2
    Uh, I don't think so ... that would prevent all SSH logins.
    – TonyG
    Oct 8 '20 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.