0

I'm testing Microsoft Azure Recovery Services (MARS), and am trying right now to run the MARS MMC plugin on a fully updated Windows 10 (2004) workstation to test restores of other servers in the Recovery Vault.

When I install MARS on this workstation, the installation proceeds just fine, reporting no errors, and finding all necessary dependencies already in place.

But when I attempt to either run Microsoft Azure Backup from the Start Menu, or manually open mmc.exe and add the Microsoft Azure Backup plugin from the list of plugins, MMC reports an unhandled exception:

Type is not resolved for member 'Microsoft.Internal.EnterpriseStorage.Dls.Utils.DlsException,CloudUtils, Version=3.0.0.0, Culture=neutral, PublicKeyToken=<redacted>'.

Exception Type:  
System.Runtime.Serialization.SerializationException

Exception Stack Trace:  
   at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
   at Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(IMessageClient messageClient, RequestInfo requestInfo)
   at Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
   at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)

Other plugins load OK in MMC, though I don't have other Azure plugins to try with, and based on the error it seems I'm missing some dependency that would tell the system what this "member" is and how it is to be used/handled, but in searching online I'm unable to find which dependency I need to install or configure, or what else may be the issue.

UPDATE:

I was trying too hard:

The issue is that the Microsoft Azure Backup plugin in mmc appears to have to run as admin, or as the account the registration wizard ran as. I'm going to try a few different scenarios to figure out specifically what the case is, but here's what I've found so far:

Because this workstation wasn't going to be backing up, I skipped the registration wizard during initial install (installer run as local admin) and then attempted to load the client as a regular user, which generated the error I encountered.

Upon installing on a different computer, I went through the registration wizard (initiated by the installer, so running as the same admin account) and then had the wizard open the client once it was complete, which meant the client loaded as admin/the same account that installed and ran the registration wizard. I then opened the client as the regular account and had the same error as on the other computer.

Then I went back to the first computer, initiated the registration wizard as admin, completed this, and confirmed that when I ran the client as admin/the same account that ran the registration wizard it loaded successfully.

Next week I hope to try this again, but getting the registration wizard to run as the regular user account rather than admin, and see if I can get the client to run without requiring local admin.

0

I was trying too hard:

The issue is that the Microsoft Azure Backup plugin in mmc appears to have to run as administrator.

Well, first you need to run the Register Server Wizard, which, by default, runs as the installer finishes, or you can manually run PostSetup.exe from the the \bin directory in the folder you installed Microsoft Azure Recovery Services to, and then you need to run the MMC/plugin as administrator.

I tried various methods, including granting a regular user full control on the installation directory, and was unable to run the PostSetup.exe Register Server Wizard except as local admin on the computer, and then I was only able to run the MMC/Plugin using an admin account. I only have one admin account to work with at the moment, and so I do not yet know if registering the server with one account allows the MMC/Plugin to be run as a different admin user. But I have answered my own questions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.