0

I have a domain which has a virtual environment as well as several physical machines (mostly laptops). RDP is enabled via group policy. On the physical machines, never the virtuals oddly enough, I keep running into a problem where intermittently, the RDP service is disabled after a reboot. enter image description here

I've ruled out a firewall issue. Those settings are pushed out with GPO as well. I also made a GPO to explicitly set the termservice to be "automatic" but that hasn't solved the problem either. Someone suggested that policy might be trying to applied before the physical machines have established a network connection, so I made a GPO to delay that using these instructions

https://docs.microsoft.com/en-us/troubleshoot/windows-client/group-policy/fail-to-apply-group-policy-at-startup

This also did not fix the problem. All of the physical machines are Windows 10 Enterprise and fully patched. There's one laptop I RDP to all the time, so I notice it the most there, but I've also noticed it on other physical machines. Sometimes I can reboot the laptop a dozen times, and RDP will work every time. Other times I can reboot over and over and RDP will fail.

When it fails, I enter-pssession to the laptop via powershell and I can see the termservice is stopped. If I physically go to the machine and look at the services, the startup type is set to disabled, but "Allow remote connections to this computer" is checked. I've checked the event viewer on the machine I see this the most on, and the only thing I can find is "'Failed CreateVirtualChannel call on this Connections Stack' in CUMRDPConnection::CreateVirtualChannel at 2622 err=[0x80070032]"

I'm at a complete loss as to why this is happening as this should be a simple and straight forward thing to achieve.

Any help would be greatly appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.