0

I'm new to website hosting. Today i registered a new domain name in Route53 and tried to connect my EC2 instance ip to it. I can notice that the domain name is moved from registration pending list to registered list, which seemed fruitful. So, I added the "A type" and "CNAME" records to the hosted zone. After all these steps, its not working as expected.
Please assist me. If I'm missing something please let me know.

Steps which I've Followed after Registering a domain name in Route53:

  1. Configured a static elastic IP for EC2 instance. (Its working)
  2. Created a new Route53- HostedZone for that domain.
  3. Two records where already there of type NS and SOA.
  4. I've added 2 more types A and CNAME.
  5. For A - domain name(xyz.in) and value (ip of EC2).
  6. For CNAME - domain name prefix (www) and value domain name(xyz.in)
  7. Finally saved the records.(Total 4 records)

In case if I'm missing something please let me know.

  • About a minute. – Michael Hampton Oct 25 '20 at 20:37
  • @MichaelHampton Hello!! Its still not working. I've updated my steps in the question. Please help me. – vijayraj34 Oct 27 '20 at 6:16
  • Your domain ayz.com still shows its nameservers as ns1.parkingcrew.net and ns2.parkingcrew.net and still seems to be registered to them. Did they actually transfer this domain to you correctly? It doesn't appear so. – Michael Hampton Oct 27 '20 at 6:20
  • My domain name is diff. grafv.in. – vijayraj34 Oct 27 '20 at 6:21
  • You should not have needed to create a hosted zone for the domain; it should have already been created for you. Anyway, the registered DNS servers for your domain are refusing queries for the domain. Check for an existing hosted zone you may have missed. Also check your nameservers under Registered Domains and ensure that they are the same as those in the hosted zone. – Michael Hampton Oct 27 '20 at 6:36
0

DNS propagation usually takes up to 72 hours:

When an IP address, or any other information about a hostname, is added or changed in a DNS record, the change needs to be propagated to all systems around the world participating in the DNS process.

DNS propagation is the time frame it takes for DNS changes to be updated across the Internet. A change to a DNS record—for example, changing the IP address defined for a specific hostname—can take up to 72 hours to propagate worldwide, although it typically takes a few hours. For many modern use cases, these DNS propagation times are inconvenient, or simply unacceptable.

  • Okay, lemme wait for the time frame. – vijayraj34 Oct 25 '20 at 15:30
0

I resolved this by adding Name Servers (NS) Manually to the Domain name under Domain registration. While creating/registering domain name, AWS added dummy or old address. Which I actually replaced it with NS from Hosted Zone. One important point is we've to copy them one by one into each NS box provided.

After few minutes it worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.