0

I'm running MariaDB 10.1.47 and trying to set:

tmp_table_size = 64M
max_heap_table_size = 64M

I've set it under both the [server] and [mysqld] sections of my.cnf I've tried setting it in bytes with:

tmp_table_size=67108864
max_heap_table_size=67108864

Running systemctl restart mariadb.service && mysqladmin variables I still only see them both set to 50331648 (48M) There are no other .cnf files anywhere that I can find it set to another value. Also my.cnf is the last config file to load so it should override all others.

Could anyone tell me what I am doing wrong here?

0

I went through my .cnf file and noticed that I had some inline comments. Example: skip-log-bin #Disable binary logging

After deleting those it is now accepting my values for tmp_table_size and max_heap_table_size

What is strange is that this was only affecting those settings and none of the others in the .cnf file.

2
  • That should not affect the prevent setting on the Primary. Were you concerned only about the Replica? – Rick James Oct 31 '20 at 16:26
  • I don't have replication set up. It was affecting the Primary for some reason. I really don't know why other than the comments. After removing those, it worked. – steveH Nov 1 '20 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.