0

I've got some files which I would like to sync to a linux server. Only problem is it resets the ownership and group to the current user and group.

Unfortunately the options --owner, --group, and --archive are somewhat unworkable because the source is a windows machine. (it's ownership doesn't make sense on the server)

Any way to keep destination ownership unchanged?

Command i'm using (minimal example):

rsync SRC $remote:DEST

1

Try rsync -azvr something somwhere:/location/.

0
1

Identify the user and group on the remote end. Example user "user1" and group "user1".

  1. add "--chown user1:user1" to your rsync command

  2. Alternatively if your version of rsync does not support that, on the remote, run "chown -R user1:user1 *" inside the highest folder of your destination file tree and this will recursively reown everything to user1. (WARNING: this syntax also changes everything in the current folder)

0

Just use --inplace option:

rsync --inplace SRC $remote:DEST

Correctly does not change destination ownership (or permissions), regardless of what the source's are.

Documentation:

--inplace

This option changes how rsync transfers a file when the file's data needs to be updated: instead of the default method of creating a new copy of the file and moving it into place when it is complete, rsync instead writes the updated data directly to the destination file.

[Warning: May cause issues when changing files that are in-use]

For full details see rsync docs page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.