1

I'm running a virtual Machine on VirtualBox 6.0.24. The VM is running Ubuntu 20.04. If I run the VM on my Windows 10 host, I can connect to the Ubuntu guest OS via both SSH and RDP.

I then copy the VM to my Debian 10.6.0 host machine and spin it up. Here I can connect to it via SSH, but when trying RDP, I get connection reset by peer. I have tried connecting both locally on the Host and from over my network. Same result.

The Debian extension pack for Virtual box is installed on the Host and matches the virtual box guest addons installed on the Guest, if version matching matters here.

There is nothing the syslog to give any clue to an issue. It's the same VM, unaltered between Host machines. There is no firewall running on the Debian Host. Running to command sudo lsof -i -P -n | grep LISTEN gives the following result. NB: On the host OS the RDP port is set to 33890. This is mapped to 3389 in the VM settings file. This worked OK on the Windows host.

cupsd      796        root    6u  IPv6  13466      0t0  TCP [::1]:631 (LISTEN)
cupsd      796        root    7u  IPv4  13467      0t0  TCP 127.0.0.1:631 (LISTEN)
sshd       847        root    3u  IPv4  20851      0t0  TCP *:22 (LISTEN)
sshd       847        root    4u  IPv6  20853      0t0  TCP *:22 (LISTEN)
VBoxHeadl 2296        root   19u  IPv6 394646      0t0  TCP *:33890 (LISTEN)
VBoxHeadl 2296        root   22u  IPv4 382556      0t0  TCP *:33890 (LISTEN)
VBoxHeadl 2296        root   23u  IPv4 382557      0t0  TCP *:222 (LISTEN)

I'm at a loss what to try so any suggestions are gratefully received.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.