2

I upgraded my server today from Debian 9 to Debian 10 and installed PHP 7.3 with all modules needed for NC but when I try to open the website I get "internal server error. More details can be found in the server log" but there is nothing helpful (for me).

So please tell me where I can find information what problem my Nextcloud has. Other PHP based sites on same server are working fine. Here some details and log entrys from the server:

  • PHP 7.3.24
  • OS Debian 10.6
  • Apache 2.4.38
  • Nextcloud 16.0.11

nextcloud error log (debug level):

[Sat Nov 14 12:39:40.862690 2020] [proxy:debug] [pid 30052:tid 140451933021952] proxy_util.c(2406): [client 87.172.229.216:64468] AH02545: fcgi: has determined UDS as /run/php/php7.3-fpm.sock, referer: https://myDomain.de/
[Sat Nov 14 12:39:40.862857 2020] [proxy:debug] [pid 30052:tid 140451933021952] proxy_util.c(2578): [client 87.172.229.216:64468] AH00947: connected /var/www/html/nextcloud/index.php to httpd-UDS:0, referer: https://myDomain.de/
[Sat Nov 14 12:39:40.862916 2020] [proxy:debug] [pid 30052:tid 140451933021952] proxy_util.c(2949): AH02823: FCGI: connection established with Unix domain socket /run/php/php7.3-fpm.sock (*)
[Sat Nov 14 12:39:40.874073 2020] [proxy:debug] [pid 30052:tid 140451933021952] proxy_util.c(2331): AH00943: FCGI: has released connection for (*)
[Sat Nov 14 12:39:40.874123 2020] [http2:debug] [pid 30052:tid 140451933021952] h2_task.c(87): [client 87.172.229.216:64468] AH03348: h2_task(64-15): open output to GET myDomain.de /index.php
[Sat Nov 14 12:39:40.874262 2020] [http2:debug] [pid 30052:tid 140451916187392] h2_session.c(1387): [client 87.172.229.216:64468] AH03073: h2_stream(64-15,HALF_CLOSED_REMOTE): submit response 500, REMOTE_WINDOW_SIZE=12582912
[Sat Nov 14 12:39:40.874298 2020] [http2:debug] [pid 30052:tid 140451916187392] h2_session.c(1541): [client 87.172.229.216:64468] AH02936: h2_stream(64-15,HALF_CLOSED_REMOTE): resumed
[Sat Nov 14 12:39:40.874326 2020] [http2:debug] [pid 30052:tid 140451916187392] h2_session.c(593): [client 87.172.229.216:64468] AH03068: h2_session(64,BUSY,1): sent FRAME[HEADERS[length=67, hend=1, stream=15, eos=0]], frames=10/4 (r/s)
[Sat Nov 14 12:39:40.874369 2020] [http2:debug] [pid 30052:tid 140451916187392] h2_session.c(593): [client 87.172.229.216:64468] AH03068: h2_session(64,BUSY,1): sent FRAME[DATA[length=289, flags=1, stream=15, padlen=0]], frames=10/5 (r/s)
[Sat Nov 14 12:39:40.874484 2020] [http2:debug] [pid 30052:tid 140451916187392] h2_bucket_beam.c(1279): [client 87.172.229.216:64468] beam(64-15,output,closed=1,aborted=1,empty=1,buf=0): AH03385: h2_task_destroy, reuse secondary
[Sat Nov 14 12:39:40.874545 2020] [http2:debug] [pid 30052:tid 140451916187392] h2_session.c(1698): [client 87.172.229.216:64468] AH03078: h2_session(64,IDLE,0): transit [BUSY] -- no io (keepalive) --> [IDLE]
[Sat Nov 14 12:39:40.879559 2020] [http2:debug] [pid 30052:tid 140451899385600] h2_session.c(341): [client 87.172.229.216:64468] AH03066: h2_session(64,IDLE,0): recv FRAME[SETTINGS[ack=1, stream=0]], frames=10/5 (r/s)
[Sat Nov 14 12:39:45.879604 2020] [http2:debug] [pid 30052:tid 140451907786496] h2_session.c(593): [client 87.172.229.216:64468] AH03068: h2_session(64,IDLE,0): sent FRAME[GOAWAY[error=0, reason='timeout', last_stream=15]], frames=11/6 (r/s)
[Sat Nov 14 12:39:45.879797 2020] [http2:debug] [pid 30052:tid 140451907786496] h2_session.c(753): [client 87.172.229.216:64468] AH03069: h2_session(64,IDLE,0): sent GOAWAY, err=0, msg=timeout
[Sat Nov 14 12:39:45.879838 2020] [http2:debug] [pid 30052:tid 140451907786496] h2_session.c(1698): [client 87.172.229.216:64468] AH03078: h2_session(64,DONE,0): transit [IDLE] -- local goaway --> [DONE]
[Sat Nov 14 12:39:45.879849 2020] [http2:debug] [pid 30052:tid 140451907786496] h2_session.c(1698): [client 87.172.229.216:64468] AH03078: h2_session(64,CLEANUP,0): transit [DONE] -- pre_close --> [CLEANUP]
[Sat Nov 14 12:39:45.880031 2020] [ssl:debug] [pid 30052:tid 140451907786496] ssl_engine_io.c(1106): [client 87.172.229.216:64468] AH02001: Connection closed to child 65 with standard shutdown (server myDomain.de:443)

Nextcloud access log

[14/Nov/2020:12:35:09 +0100] "GET /status.php HTTP/1.1" 500 -
[14/Nov/2020:12:35:09 +0100] "GET /status.php HTTP/1.1" 500 -
[14/Nov/2020:12:35:41 +0100] "GET /status.php HTTP/1.1" 500 -
[14/Nov/2020:12:35:41 +0100] "GET /status.php HTTP/1.1" 500 -
1
  • Did you ever find a solution to this? – RolandiXor May 19 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.