This is the latest:

The Terminal Server and TS Licensing features have been uninstalled from the upgraded server. RDP access is allowed in the Remote tab. (Check out the comments on the first answer for that detail, if necessary.) Still, RDP access is broken.

I found out that the Terminal Server service in the Services MMC is broken. First, it still contains the Windows 2000 description. Second, it points to the old Win2k Server executable. It obviously doesn't work.

I have a Windows 2000 DC that was running Terminal Services in Application Mode. A couple of weeks back, I ran an in-place upgrade to 2003. The server is now running 2003 R2 Standard.

Since then RDP no longer works. We have no need or desire for this to be a Terminal Server anymore other than Administration Mode.

What I am really trying to accomplish is the following:
Place the upgraded 2003 server into Remote Desktop for Administration.

(Interestingly, the "Licensing" setting within the Terminal Services Configuration MMC is not visible.)

At the moment, Terminal Services is installed on the server, but licensing is not. We were trashing around trying to resolve this and that's the state we've left the server. I've since discovered that for a typical configuration, neither the Terminal Services nor the Licensing features should be installed.

If anyone has any thoughts, they are appreciated.

Also: This is a production server. I can reboot it, but must do so off-hours.

Some new details:

RDP is "broken" in the sense that when any client attempts to initiate a connection to the server, they immediately receive a "This Computer cannot connect to the remote computer" error.

Also: There is no "Remote" tab within the Properties sheet for My Computer.


  • At this point is there anything in the event logs? What SP is installed?
    – joeqwerty
    Jan 20 '10 at 3:45
  • I will check as soon as I can.
    – tcv
    Jan 20 '10 at 4:02
  • The primary error that seems related to Terminal Services is in the System Log: The System Cannot Find the File Specified, which is what happens when you try to start the Service because ... it's looking for pre-Win 2003 Terminal Services executable: C:\WINNT\System32\termsrv.exe
    – tcv
    Jan 20 '10 at 23:11
  • What SP is installed? Try installing or re-installing SP2 and see if that fixes the issue. I'm thinking it's going to copy the missing file or files that are needed.
    – joeqwerty
    Jan 21 '10 at 0:04
  • I'm sorry. I neglected to get that for you. It's running Service Pack 2. Is there anything you can tell me about reinstalling SP2? Any gotchas?
    – tcv
    Jan 21 '10 at 3:17

If you want to use it in remote administration mode (which is a term that was deprecated in W2K3) then simply uninstall the Terminal Services and Terminal Services Licensing components from the server and from your environmet (if TS Licensing was installed on another server).

  • I thought we tried that, but am unsure. It was late. I was drunk. That's my story. I will try this tonight. :-)
    – tcv
    Jan 19 '10 at 18:54
  • From Add Remove Programs make sure to go into Windows Components to look for both and remove them if they're there. Also, when you say RDP no longer works, what exactly is happening? Is Remote Desktop enabled? Do you have the appropriate users\groups selected for Remote Desktop access?
    – joeqwerty
    Jan 19 '10 at 19:05
  • RDP no longer works meaning when attempting to connect with a client, you immediately receive a "This computer can't connect to the remote computer" error. As for as I know, I am unable to enable remote desktop as there's no "Remote" tab in the Properties sheet for My Computer.
    – tcv
    Jan 19 '10 at 20:34
  • Hmm... Here's something from the interwebs: run the following from a command line: regsvr32 remotepg.dll
    – joeqwerty
    Jan 19 '10 at 20:45
  • Dare to do before I remove features? Responsibility is not yours! ;-) TRIGGER PULLED. The Remote Tab is back and the option is on. (It was on already.)
    – tcv
    Jan 19 '10 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.