All involved OSes are Debian 10

I run a decent size network for a scientific insitute. Users have separate PCs to work on. Login is handled locally. To connect users and data, we run a samba server ("cloud" -- just to share data, separate login details) and a login server ("node") that's accessible worldwide Users can successfully use the "archive" share on "cloud" via Nautilus or Dolphin. However I want to enable them to also mount / access the cloud on the "node"

I have installed gvfs-backends and gvfs-fuse and added all users to the fuse group.

Using gio mount smb://cloud.[fqdn]/archive root can mount the share using any samba-username + password and access it in /run/user/0/gvfs/

Doing the same with any non-root user yields volume doesn't implement mount.

I have no idea how to interpret that since the volume is obviously mountable.

2 Answers 2


Based on this answer for another question, the issue might be the lack of a dbus session. See:

laptop $ ssh pi
pi $ gio mount smb://
gio: smb:// volume doesn’t implement mount

After connecting to my headless Raspberry Pi over ssh, I can't mount things using gio/gvfs. Then, I can start a dbus session and run a new shell inside it:

pi $ dbus-run-session bash

pi $ gio mount smb://
Password required for share foobar on

pi $ mount | tail
gvfsd-fuse on /run/user/1002/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1002,group_id=1002)

pi $

As soon as that dbus session ends, the mount gets umounted.

  • 1
    I just plain didn't realize that gio mount could not be used in a regular ssh session for a user that already has a dbus session due to being logged in locally -- it has to be done in the local login session (or presumably with whatever environment vars that are needed to find the dbus session set)
    – rakslice
    Sep 24, 2021 at 20:47

I encountered this issue when getting a Debian 10 system up and running with the command line only at first with no desktop environment yet installed.

After installing the packages:

sudo apt install gvfs-fuse gvfs-backends libglib2.0-bin

I attempted an SMB mount with gio while logged in as my regular user (the one created by the Debian installation with uid 1000), but I got the same volume doesn't implement mount error.

I noted that the depended-upon gvfs-daemons package containing gvfsd had a configuration for a service that runs as a regular user in its package:

$ dpkg -L gvfs-daemons

To manually launch that in an already logged-in regular user session, I did:

systemctl --user start gvfs-daemon

After that the gio mount worked without issue and I was able to access the mounted volumes under /run/user/1000/gvfs/.

I haven't had to do this manually in later sessions -- it may only be necessary in a login session that was already running before the package was installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.