0

Problem

The NFS-Client of Windows10 Pro mount an NFS-share with lang=ansi by default. This causing problems using filenames with umlauts or asian characters (e.g. Kanji, Hiragana, Katakana, etc).

Details about my setup

Server is Debian GNU/Linux 10.6 (buster). Support NFS-Version by that server from 3 to 4.2 (2 is disabled):

$ sudo cat /proc/fs/nfsd/versions
-2 +3 +4 +4.1 +4.2

The client is Windows10-Pro build 19041. It is unknown for me which NFS-protocol version is used by the client. This are the options for the mount point.

UID=-2, GID=-2
rsize=131072, wsize=131072
mount=soft, timeout=0.8
retry=1, locking=yes
fileaccess=755, lang=ANSI
casesensitive=no
s=sys

I know there are other options for lang=.

euc-jp: Japanese
euc-tw: Chinese
euc-kr: Korean
shift-jis: Japanese
Big5: Chinese
Ksc5601: Korean
Gb2312-80: Simplified Chinese
Ansi: ANSI-encoded

But none of them looks usefull for me.

Is there any possible solution?

0

AFAIK, windows supports NFSv3, which is uses XDR string as a type for the file names., which is limited to ASCII:

NFSv3 spec https://tools.ietf.org/html/rfc1813#section-2.5

typedef string filename3<>;

https://tools.ietf.org/html/rfc1014#section-3.10

The standard defines a string of n (numbered 0 through n-1) ASCII bytes to be the number n encoded as an unsigned integer (as described above), and followed by the n bytes of the string.

IOW, NFS v3 doesn't supports unicode

https://tools.ietf.org/html/rfc1813#section-3.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.