0

I have a test server and a prod server that host a .netcore2.1 website. On the test server, I can access to the website and publish with MSDeploy without any problem.

On the prod server I can publish correctly from Visual Studio, everything is setting like on the test server but I have this when I try to open the website:

Http Error 500.19
Error Code    0x8007000d
Config File   \\?\C:\MySite\web.config

I have the same configuration on both server, same version of program, web deploy 3.6 and URL rewrite installed.

The only visible difference is in the Services where the Web deployement agent Service is not listed on the prod server. However I had checked it in the Webdeploy install process.

Interesting thing: When I publish with the "Self-contained" option, the website is displayable so I suspect a missing thing but I don't find what.

I tried a lot of thing by searching on forum and microsoft documentation but nothing solve this problem.

6

1 Answer 1

0

I had exact the same issue with a CyberArk website (on IIS10) for load balancer monitor service. After installing the website, a repair of the MS .NET Core 3.1.22 Bundle solved the issue

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .