0

I'm currently working with mariadb and phpmyadmin on my debian 10 server. For some reason mariadb only allows passwords with a maximum length of 79 characters. If I specify a password that is longer than 79 characters I can easily login to phpmyadmin over the loginpage. But when I try to login to mariadb over the command prompt with the same password I get the error response: "ERROR 1045 (28000): Access denied for user 'user'@'localhost' (using password: YES)". Is there a way to enable longer passwords?

Thanks for your time and help.

1

The mariadb client and related tools have an inbuilt 80 character when reading tty passwords.

This doesn't apply to the password command line argument, environment variables or configuration files specification.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.