0

I am having a problem with my CentOS 7 server

By accident i run command

# firewalld

Then i found that the log file in /var/log/firewalld was updated with the following

2020-11-26 12:59:08 WARNING: AllowZoneDrifting is enabled. This is considered an insecure configuration option. It will be removed in a future release. Please consider disabling it now.

I checked the firewall status, which gave me inactive

# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:firewalld(1)

but when I checked firewall-cmd it says it is running

# firewall-cmd --state
running

I tried to stop it using following command but nothing changed

    systemctl stop firewalld 
    systemctl disable firewalld

Any idea how to stop the firewall?

Your help is really appreciated

1

It is most likely the case where the process is hanging even is the service is disabled. Due to the firewall being started manually not using the daemon.

So run ps aux |grep firewalld and kill that process.

3
  • Thank you so much this is fixed my problem
    – Wejdan M
    Nov 29 '20 at 8:36
  • 1
    More accurate is that the daemon was started manually and not as a service managed by systemd. Since firewalld was not running from a managed service unit attempting to use systemd to stop it were unsuccessful.
    – Bob
    Nov 29 '20 at 8:57
  • @HermanB that is right the firewall was started by me manually accidently and not through service
    – Wejdan M
    Nov 29 '20 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.