0

I'm running an RHEL4 server with Apache 2.0, and I need PHP 5.2.1 - 5.2.11 for SugarCRM Pro 5.5.0. I also need to run it side-by-side with another version of PHP, so I compiled it from source for CGI. Problem is, I keep getting an Internal Server Error only on certain pages:

[Tue Jan 19 20:53:53 2010] [error] [client 69.106.58.53] * glibc detected * double free or corruption (out): 0x008df858 ***, referer: https:// (removed for privacy) /index.php?action=Login&module=Users&login_module=Home&login_action=index

[Tue Jan 19 20:53:53 2010] [error] [client 69.106.58.53] Premature end of script headers: php-cgi-5.2.11, referer: https:// (removed for privacy) /index.php?action=Login&module=Users&login_module=Home&login_action=index

I've also tried running "sudo up2date --update", and tested every version of PHP from 5.2.1 to 5.2.12 with no luck.

This is what my PHP configuration looks like:

make clean && ./configure --prefix=/usr/local/php-5.2.11 --enable-fastcgi --enable-force-cgi-redirect --enable-discard-path --enable-mbstring --with-libxml-dir --with-pear --with-curl --with-openssl --with-kerberos --with-zlib --with-mysql --with-pdo-mysql --with-imap --with-imap-ssl && make && sudo make install

What should I do at this point? Is there an RPM somewhere that I can use?

| improve this question | | | | |
2

This post is old but i think is better providing a solution if has been discovered.

I have solved simply setting the environment variable MALLOC_CHECK_ explicitly to 0: setenv MALLOC_CHECK_ 0

in the RHEL4 Documentationdocs is explained the cause of the problem (in the section Package Specific Notes / glibc).

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.