Booting my very capable PC has become a fingers-on-chalkboard-grating slow nightmare because of snap. It's gone from 5-10 seconds to login screen after GRUB to now 30-45 seconds, sometimes up to a minute or more.

This is absurd.

I'd prefer to not remove every single snap on my machine, but I'm prepared to do that. How do I defeat snap mounts on boot and regain my sanity, without having to scorch the earth?

Specifically looking for an answer to this: how do I modify individual snaps so that they do not mount during boot?

$ systemd-analyze blame
          8.812s plymouth-quit-wait.service
          6.256s NetworkManager-wait-online.service
          5.042s bolt.service
          3.008s snap-spotify-42.mount
          2.994s snap-gnome\x2dlogs-93.mount
          2.917s snap-discord-115.mount
          2.525s snap-chromium-1399.mount
          2.515s snap-gnome\x2dlogs-100.mount
          2.416s snap-gtk2\x2dcommon\x2dthemes-13.mount
          2.392s snap-gnome\x2dcharacters-550.mount
          2.224s snap-gnome\x2d3\x2d34\x2d1804-36.mount
          2.214s snap-gtk\x2dcommon\x2dthemes-1513.mount
          2.174s snap-gnome\x2d3\x2d28\x2d1804-145.mount
          2.170s snap-gnome\x2dcalculator-748.mount
          2.149s snap-postman-128.mount
          1.953s snap-storage\x2dexplorer-17.mount
          1.946s snap-core18-1885.mount
          1.749s systemd-fsck@dev-disk-by\x2duuid-db865690\x2db43f\x2d485b\x2d8bab\x2d808735a403a8.service
          1.725s unifi-video.service
          1.632s dev-loop3.device
          1.632s dev-loop2.device
          1.575s dev-loop5.device
          1.557s dev-loop6.device
          1.555s dev-loop7.device
          1.464s dev-loop9.device
          1.452s dev-loop8.device
          1.441s snap-gnome\x2dcharacters-570.mount
          1.426s snap-core-10185.mount
          1.409s snap-spotify-43.mount
          1.400s snap-libreoffice-196.mount
          1.384s snap-gtk2\x2dcommon\x2dthemes-9.mount
          1.380s snap-gnome\x2d3\x2d34\x2d1804-60.mount
          1.370s snap-postman-129.mount
          1.214s dev-loop10.device
          1.135s dev-loop11.device
          1.132s dev-loop1.device
          1.089s dev-loop21.device
          1.072s snap-vlc-1620.mount
          1.070s dev-loop19.device
          1.054s dev-loop18.device
          1.041s dev-loop20.device
           981ms dev-loop12.device
           975ms dev-loop14.device
           968ms systemd-logind.service
           944ms dev-loop4.device
           903ms dev-loop13.device
           902ms dev-loop17.device
           901ms dev-loop16.device
           881ms dev-loop22.device
           834ms snap-core18-1932.mount
           809ms snap-chromium-1411.mount
           681ms nvidia-persistenced.service
           678ms snap-gnome\x2d3\x2d28\x2d1804-128.mount
           669ms dev-loop15.device
  • 1
    This question appears to be off topic. You may be able to get help on one of our sister sites such as Unix & Linux or Ask Ubuntu. Dec 2, 2020 at 15:51
  • Good point, thanks @MichaelHampton - I'll move this over to Ask Ubuntu. Thanks!
    – Rob
    Dec 2, 2020 at 16:51

1 Answer 1


hmm. Remove unwanted snaps (and possibly replace them with debs), or

systemctl disable snapd.service will solve your problems, permanently.

If you don't want to be that radical, you have to decide on how you would want your desired snaps to start: on demand, during boot or spread over some time after boot? Each of these approaches has it's own set of downsides that must be considered for particular use case.

Personally, I try to minimize amount of installed snaps to the bare minimum, and they don't bother me much.

  • 1
    I guess that's the core of my question - how do I change individual snaps so that they do not mount during boot?
    – Rob
    Dec 2, 2020 at 16:47
  • 2
    If I want them to start on-demand, how do I do this?
    – 0xLogN
    May 12, 2021 at 20:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .