0

I have a working L2TP VPN that I can ping all clients once connected, name resolution does not work but I believe that is a separate issue. I cannot connect using RDP between two Windows 10 machines. I can RDP connect from a Windows 10 laptop to an old Windows Home 2012 Server across the VPN, I can also use the following 'telnet (IP address) 3389' to verify the connection to the Windows Home Server. Inside both local LANs, RDP works fine between Windows 10 machines, just not across the WAN/VPN. Both networks connected over the VPN have different IP address ranges. I also have 'Require computers to use Network Level Authentication to connect' turned off on the machines I am trying to connect to. I am using a centrally managed Bitdefender firewall on each machine at both sites. I have opened ports 3389 TCP/UDP for all IP addresses on the local machines, as well as the for the RDP service at '%WINDIR%\system32*svchost.exe*'. (svchost.exe should be mstsc.exe) I have a setting set on the Home Server to allow all versions of RDP to connect but I have not found anything similar on the Windows 10 RDP settings. I have verified that the machines in question are listening on 3389 as well. Any ideas, I am all ears? Thanks in advance for any help.

NEW INFO as of 12/31/2020: Okay, some critical updates and what I have figured out so far. I know the problem is with Bitdefender and allowing edge traversal with RDP. I did several tests and here is what I found. First I turned off all local (machine) firewalls and everything works fine. I then found some articles on configuring the Windows firewall (after turning off Bitdefender firewall on local machines) for RDP and turned on the three rules needed to allow incoming RDP connections. In addition, I discovered that this is not enough you must also allow Edge Transversal (One subnet to another) within each of the RDP protocol settings. Okay fair enough I can get everything to work with the Windows Firewall and RDP across an l2dp VPN connection into the network. The problem is I cannot figure out how to set this up on Bitdefender. Also as a point of clarity, I have laptops connecting via a VPN to a Hardware firewall router that terminates the incoming VPN. Then RDP is used to connect to the user's machine inside the network. Only on the user machine inside the network do I have the rules allowing for incoming RDP connections. The laptops can be in a public or private connection state and have a separate firewall profile/policy that does NOT allow RDP incoming connections. So what I am saying is users are using a laptop to take over their office computers via RDP through a secure l2dp VPN. Any suggestions would be great, thanks in advance. Also, I had the wrong file listed for the RDP application it is mstsc.exe not svchost.exe

0

I finally heard back from Bitdefender Enterprise and they sent me a fix. Basically, I had to add a rule to allow traffic from the VPN subnet and make that the first rule in the firewall ruleset. In my case, I just made the remote address 192.168.x.x/25 and allowed that traffic on the local subnet. Once I did this RDP worked just great over the l2dp VPN. I hope this helps other people with this problem. The same rule also fixed name resolution but with a slight modification. I can now type "machine name".local and it goes right to the right machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.