1

Im new to Openstack administration.

I have a up and running setup of Openstack Ussuri using 1 controller and 1 compute node in lab environment.

By following CentOS related guide I have already setup'ed self-service networks option on both compute and controller node.

Now I'll be appending below configuration into /etc/neutron/plugins/ml2/ml2_conf.ini file.

#Inclusion of `vlan` option in `[ml2]` section
[ml2]
tenant_network_types = vxlan,vlan

# Adding below section
[ml2_type_vlan]
network_vlan_ranges = physnet1:1:4000

Complete configuration of ml2_conf.ini can be found in here - https://pastebin.com/raw/NpP1NFGi

Does the above change in ml2_conf.ini is required a re-run of DB population command as specified in here ? - https://docs.openstack.org/neutron/ussuri/install/controller-install-rdo.html#finalize-installation

Thanks in advance.

5
  • Whether it requires a reset of the database or not depends on the change you want to make. The problem is, nobody will be willing or able to tell you which settings do require this. I doubt, by the way, that rerunning the population command would be enough. You probably have to delete the Neutron database first. Dec 30 '20 at 11:26
  • @berndbausch, I have updated question with configuration snippet which Im trying to add. Please have a look. Thanks. Jan 4 at 10:47
  • 1
    Most probably adding a tenant network type is a change deep enough that it requires recreating the database. Jan 6 at 2:33
  • @berndbausch, If you don't mind, could you please check this pastebin.com/raw/NpP1NFGi ml2_conf.ini is valid or not ? Jan 7 at 14:27
  • It doesn't seem to contain errors, but I couldn't say if something is missing (I don't have enough experience writing ML2 configurations). Jan 8 at 0:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.