7

I've just flashed the BIOS of 3 different X9SCD motherboards, all housed within different MicroCloud chassis. I've done this hundreds of times, with this exact BIOS version (x9scd8.612), with no issues. I have my own custom made FreeDOS ISO which I boot up on the IPMI KVM and run a batch file which simply executes:

AFUDOSU.EXE x9scd8.612 /P /B /N /K /R

Completed with no errors on all 3 systems. But after power cycling I can't get into the BIOS. I just end up with this screen:

BIOS AB error

The systems appears to work fine other than not being able to get into the BIOS. I was able to install Windows 2019 on one of the systems via the IPMI/KVM and boot an existing Linux OS on another. It's just entering the BIOS that seems to fail.

I noticed today that for some reason, Java wasn't allowing me to load the KVM without adding a security exception. This was only on servers running IPMI firmware 3.50. The ones on 3.54 continued to work fine. So I wonder if this is actually BMC/IPMI related? I updated the IPMI firmware on them anyway but that didn't fix it.

In addition, I've just tested another X9SCD server that hasn't been touched at all recently. It was already running IPMI 3.54 and I can't get into the BIOS on that! I'm completely puzzled as to what's going on. Anyone else finding this on X9 generation boards?

1
5

Based on user discussions in a thread by Webjunkie in the ServeTheHome Forums it appears that there is a date dependent bug that causes this behavior on some of the Supermicro X9 boards:

It seems like SuperMicro X9 boards with E3v1/v2 CPUs (X9SCL-F, X9SCL+-F, X9SCI-LN4F, X9SCA-F, X9SCM-F, X9SCM-IIF, etc) will not allow you to enter BIOS if the system date is past December 31, 2020. When attempting to enter BIOS, it comes up with a blue screen, and in the bottom right the error code "AB", which apparently means "Setup Input Wait" per SuperMicro documentation. If you clear CMOS, you can get into BIOS. We've tried with the latest BIOS (v2.3) and also older BIOSes with the same results.

Apparently the problem can be worked around by either clearing CMOS to reset the RTC or by booting an OS and using its tooling (eg hwclock) to set the RTC to a date prior to 2021.

According to their discussion there, Supermicro are aware of the problem:

I just received an update from SuperMicro:

"We are aware of this issue and working internally to address it. I will provide an update once I have more details of BIOS fixes. Please continue to use the manual work-around for now."

5
  • Thanks, the millennium bug arrived 21 years late! Jan 5 '21 at 8:41
  • 2
    Just wanted to add that you can boot the UFI shell and use the date command to set the time in the past. Just done that on a load of boards just to get into the BIOS and then set it back. Hopefully won't be long for the fix to be released. Jan 12 '21 at 14:06
  • Bios got update, here's the 2.3a link supermicro.com/about/policies/…
    – Ajay
    Jan 18 '21 at 14:40
  • I am having similar issue on X9SPU-F - I have two of these boards, so really hoping Supermicro releases a fix. How can I set date back for now using UEFI shell? Jan 18 '21 at 22:28
  • 1
    For some reason I didn't get notification of another post to this thread. I can see the new BIOS has been released for the X9SCD but if it hasn't been released for your motherboard yet, just but the shell (F11 on POST) and type "date 01/01/2020" or something. It's really that simple. Jan 25 '21 at 18:54
2

I have just received a first untested BIOS version which fixes the bug for my X9SCM-F board from Supermicro. The previous version was 2.3 Now the board is on 2.3a and is working just fine

So you may expect fixed bios versions for the affected boards shortly.

bios with date bugfix

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.