Does anyone know where "Only allow a magic packet to wake this computer" setting has moved to in 2016-core?

This 2016-core server can be kept awake by continuous pings or if I let it suspend it can be woken by a Magic Packet but does not wake on ping or any other network packets.

On Server 2012 device manager for the NIC there are three check-boxes under the Power Management tab:

1).    "Allow the computer to turm off this device to save power"
2).    "Allow this device to wake the computer"
3).        "Only allow a magic packet to wake this computer"

I have identified that these are stored in the registry hive: HKLM\System\CCS\Control\Class{4D36e972-E325-11CE-BFC1...}\nnnn\PnPCapabilities (DWord)


24 - 1=off, 2=off, 3=off
16 - 1=on, 2=off, 3=off
0 - 1=on, 2=on, 3=off
256 - 1=on, 2=on, 3=on

I suspect that this setting is enabled by default, how do I disable it in Server-core?

Set-NetAdapterAdvancedProperty -Name "Ethernet" -DisplayName "Wake on magic packet" -DisplayValue "Disabled"  

To see the current values:

Get-NetAdapterAdvancedProperty -Name "*"  
  • Unfortunately not, this does not seem to change the: "Only allow a magic packet to wake this computer" device manager behaviour. Have tried this out on a 2012 (server with a GUI) install and found that it relates instead to the NIC Advanced tab setting rather than the Power Management tab setting. – NickC Jan 13 at 15:20
  • Is it possible that Server-Core simply doesn't support Power Saving at all? – NickC Jan 13 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.