We are using Windows Server 2008 and the built in RemoteApp feature for Terminal Services.

When we run a RemoteApp (WordPad for example), local printers are automatically redirected as expected. However, the default printer within the RemoteApp session is changed to the default printer on the local computer(!)

I have tried creating a script and assigning it within Terminal Server Configuration page to run when users logon, but this is not run when a RemoteApp is opened. It is only run when I mstsc directly to the server.

How can I set which printer is the default for the RemoteApp, even after automatic printer redirection has taken place?


In the GPO that's linked to the OU where the server running the remote app is located go to Computer Configuration|Administrative Templates|Windows Components|Terminal Services|Terminal Server|Printer Redirection and enable the "Do not set default client printer to be default printer in a session" setting. That will stop the local default printer from becoming the default printer in the remote session.

As far as the logon script is concerned, I'm not sure why it wouldn't run because when you access a RemoteApp you're actually logging on and creating a TS session on the server, but you only see the RemoteApp instead of a desktop. I've run RemoteApps and have not had problems with logon scripts.

Also, the printer behavior your seeing is actually the normal behavior (in your question you seemed surprised that it was acting this way).

  • At the risk of reviving old information. I had the direct opposite of this issue and reverse engineering the fix got me to get it fixed. Something else to check might be Remote Desktop Session Host Configuration | right click RDP-Tcp | Properties | Client Settings | Uncheck "Default to main client printer" – Travis Oct 20 '15 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.