I have a disk from a AIX server that I need to explore in order to recover some data (the server is down).

Is it possible to mount AIX partitions on Linux? How?

  • 2
    What kind of file system is the AIX server using?
    – Ophidian
    Commented Jan 21, 2010 at 14:55

7 Answers 7


just to let you know that I have written support for linux for discovering and mapping logical volumes of AIX LVM and mounting AIX JFS file systems as found in AIX 3.5 and AIX 4.1 & 4.2. More information at https://stackoverflow.com/questions/16569079/which-software-project-for-a-aix-disk-partition-scanner-for-linux


The answer is probably No. No commercial distribution comes with this ability to mount AIX's JFS filesystems. So you would need to get JFS modules built/deployed for your Linux. My understanding is that the JFS technology IBM contributed to Linux stems from OS/2 rather than AIX. See this Wikipedia on JFS:

In AIX operating system, there exist two generations of JFS filesystem that are called JFS (JFS1) and JFS2 respectively.1[2] In the other operating systems, such as OS/2 and Linux, only the second generation exists and is called simply JFS.[3] This should not be confused with JFS in AIX that actually refers to JFS1.

Therefore obtaining and building Linux JFS will likely not work.

Quicker to get maintenance on your RS6000 and get it fixed and up and running.


Yes, AIX's JFS can be mounted on Linux. You can just mount it normally using the "mount" command if you have JFS drivers installed (definitely a default with the Suse family and definitely available for Red Hat if not there by default.)

You can reference IBM's own guide for this here: http://www.redbooks.ibm.com/redbooks/pdfs/sg246622.pdf


Bit late I know, but I assume you've worked out the answer now - no you can't.

The reason isn't just the filesystem format itself, but the AIX LVM stores data on the disk in a different partition format to that of Linux's disk partitioning and LVM options.

The best option available in general is to boot from CD on another pSeries server with the hard drive attached.

  • 1
    thanks for the answer but my boss solved the problem with another RS6000 server so we don't have to mount the disk on linux anymore Commented Feb 17, 2010 at 15:00

By default, Linux cannot natively support the AIX partition table. The filesystem lies on top of the partition table, so the filesystem type does not matter since Linux cannot read AIX.

Think of a partition table in terms of this analogy of mine:

A filesystem is to files as a partition table is to filesystems.


A 'right' question is whether the filesystem that is on the disk is supported by your linux system. I do not believe that linux natively supports the jfs filesystem, which I believe from some Googling is the default AIX fs. I did find this resource regarding compiling the linux kernel with jfs support or alternatively here. If/Once your kernel supports jfs you should be able to mount it like any other disk.

You can find out the filesystems your kernel supports by looking at /proc/filesystems, eg:

cat /proc/filesystems

On a CentOS install I do not see jfs listed. Note that I have zilch exeperience with AIX and this is just an educated guess.


I don't see why you can't. Just mount it like any other disk with the mount command.

mount [options] [device] [directory to mount to]

-typical options would be: -t [fstype i.e. jfs]

-device would be something like: /dev/sda1

-directory to mount to would be something like /mnt/aix (or any directory you specify to be the root to mount the AIX drive to)

Hope that helps and good luck.

EDIT: assuming you have jfs support

  • 1
    well, before trying to mount it, I can't even list the partitions with fdisk, it warns me there is an AIX signature on the disk that is not currently supported on Linux. I've searched through the linux config and did not find any kind of "AIX partition table" support Commented Jan 23, 2010 at 15:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .