0

I am running a Windows 10 VM in VMWare Workstation 15.5.1 build-15018445. From within the VM I connect via Cisco Anyconnect to a VPN.

Connecting the VPN with a Network Adapter as

  • Bridged (Automatic) results in reconnects every minute
  • NAT results in a stable connection

Now the funny part. If I initially connect to the VPN in NAT mode, then switch in VMWare to Bridged mode and let Cisco Anyconnect do a reconnect, the connection is stable as well with the Bridged mode.

Due to that the host needs to be connected to a different VPN, I need the VM to have configured in Bridged mode and using the work-around with NAT-first is getting tired and is sometimes forcing me to disconnect the VPN on the host first which leads to futher problems.

So I am hoping someone else has experienced such issues before and does have a hint for me or a configuration advise for the VPN admins.

2
  • Yes, for ages, and it drives me crazy. Doing the thing of switching network modes also works for me thanks for the tip!
    – ricpf
    Jul 26 at 21:26
  • After a couple of updates of Windows 10, VMWare and the Cisco Anyconnect client, the problem described has be gone. Unfortunately I cannot spot which update solved the problem.
    – Thomas
    Jul 27 at 11:54
0

Change UDP timeout from 30s to 60s under VMwareNetwork Config. that solved for me. Connection stable for up 40 min

2
  • 2
    hows about to show that in a complete way?
    – djdomi
    Jul 27 at 5:47
  • Sure, under VMware main screen, click edit, virtual network editor, change settings, find the network "NAT" and select it. Below there will be a button for NAT settings. Click it. There will be a secondary screen where there is a setting for "UDP Timeout" with a value of 30. Change it to 300 (5 min), save and close everything and then start the VM (make sure it is using the NAT interface adapter). That solved for me (or at least improved a lot)
    – ricpf
    Jul 28 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.