I have a Brother MFC-7460DN. The only network feature it has is scan-to-ftp. I am used to using a Qnap NAS as a FTP server for this task which worked fine. I changed the Qnap NAS to a Debian server. The aim is to set up an FTP server (only for the local network) so I can use the scan-to-ftp feature again. The Brother is supposed to save the scans in a directory named /Family/Scans.

What I did so far:

First, installed vsftpd.

Second, modified the vsftpd.conf.

Third, created a file named /etc/vsftpd.chroot_list and added "jens" (the user the printer uses to connect to the FTP server). "jens" is a real local user with permission to modify /Family/Scans.

The Brother itself has following options: IP, user, password, destination folder, passive mode and port. The only two things I am not sure about are passive mode and port.

Whenever I try to scan-to-ftp I get an connection error without further details. So I downloaded FileZilla to test the FTP. If I use port 21 or any other I get an "ECONNREFUSED" error. If I use port 22 I get an "Access denied". I don't understand why.

The printer is not able to Scan-to-SFTP. All I want to do is to set up a plain FTP server that the printer can connect to.


 # Example config file /etc/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
# This directive enables listening on IPv6 sockets. By default, listening
# on the IPv6 "any" address (::) will accept connections from both IPv6
# and IPv4 clients. It is not necessary to listen on *both* IPv4 and IPv6
# sockets. If you want that (perhaps because you want to listen on specific
# addresses) then you must run two copies of vsftpd with two configuration
# files.
# Allow anonymous FTP? (Disabled by default).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# If enabled, vsftpd will display directory listings with the time
# in  your  local  time  zone.  The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may restrict local users to their home directories.  See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
# Customization
# Some of vsftpd's settings don't fit the filesystem layout by
# default.
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
# This string is the name of the PAM service vsftpd will use.
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.

# Uncomment this to indicate that vsftpd use a utf8 filesystem.



What's wrong with my setup?

  • Does nmap <server> show an open port 21?
    – FelixJN
    Jan 18, 2021 at 20:46
  • Only port 22 is open (due to SSH most likely). I thought as soon as the ftp server is running the associated ports are open. How do I open port 21?
    – user613057
    Jan 18, 2021 at 22:06
  • How about nmap -6 <server>?
    – FelixJN
    Jan 18, 2021 at 22:27
  • connection refused means that the server actively refuses to set up a connection, as opposed to simply ignoring a connection request. I can imagine two reasons: A firewall on the NAS rejects connections, or the FTP server is simply not running. You can use a command like netstat -lntp | grep ':21' to see if any processes listens on port 21. Jan 19, 2021 at 2:48
  • netstat -lntp | grep ':21' is dong nothing.
    – user613057
    Jan 19, 2021 at 19:46

2 Answers 2


It sounds like your ftp server isn't running. I compared your vsftpd.conf with mine and they're similar enough.

 ps -ef|grep vsftp

This should show /usr/sbin/vsftpd /etc/vsftpd.conf is running.

If not then if using systemctl

systemctl enable vsftpd
systemctl start vsftpd

if using an older version

chkconfig --level 35 vsftpd on
service vsftpd start

I'm assuming that you have already opened firewall ports for 20 and 21 (20 is for data and 21 is for commands). If not, there's plenty of guides for opening ports based on whichever firewall you're using (ufw, iptables, firewalld etc).

  • ps -ef|grep vsftp is showing adminis+ 9267 8947 0 20:47 pts/0 00:00:00 grep vsftp I did the start and enabling, no change. Well, I am not using any firewall since the server is only serving the local network. Is there usually anything pre-installed I am not aware of?
    – user613057
    Jan 19, 2021 at 19:50
  • That's just showing your grep command which suggests that vsftpd is not running. Check your syslog for any error messages. If you have net-tools package installed, as root, run "netstat -anp|grep :21|grep LISTEN" and this will show if something is already listening on port 21, along with what it is and the process id.
    – nelgin
    Jan 20, 2021 at 20:04
  • Executing 'systemctl enable vsftpd' shows: Synchronizing state of vsftpd.service with SysV service script with /lib/systemd/systemd-sysv-install. Executing: /lib/systemd/systemd-sysv-install enable vsftpd Failed to reload daemon: Access denied Failed to reload daemon: Access denied Failed to enable unit: Access denied So for some reason I can not start the service.
    – user613057
    Apr 3, 2021 at 9:33
  • Well, forgot sudo. Apparently the command is executed but nothing happens.
    – user613057
    Apr 3, 2021 at 9:50

If your service is runing fine then you have to first check that Port21 is used by some other program or not by using this command:

sudo netstat -tunlp|grep ':21'

If it's not used by any program then you have to check the iptables and firewall-cmd rules to check any blockage from your server side:

iptables -L
firewall-cmd --list-all

  • Port 21 is not used at all so no program is listening on port 21.
    – user613057
    Apr 3, 2021 at 9:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .