6

We have a new installation of SQL Server 2005. The server doesn't have access to the internet and we've disabled the checks for certificate revocation but don't want to continue to do this as it is dangerous. But are still having these really slow start times (upwards of 60 seconds).

1
  • It would probably be helpful if you more accurately characterize what "really slow" means in your case? You should also probably mention if it's only slow on the first load or slow on every load. – Ryan Bolger May 20 '09 at 19:46

10 Answers 10

8

In Tools - Options, go to the Environment - General section and for the At Startup option, select Open empty environment. See if that improves anything.

1
  • Worked like a charm! THANKS!!! Hopefully this will now be the conical answer instead of building firewall rules or proxy servers. – Keng May 21 '09 at 13:34
2

I hate using SSMS because it is slow and cumbersome. The older Enterprise Manager in SQL 2000 was quick to load and much snappier in reponse to actions. That's progress for you.

2
  • 3
    +1 agreed; and find me something that loads as quick as query analyzer did. luckily it still works even with 2005/2008. I use sqlcmd more and more. Progress! – SqlACID May 21 '09 at 2:12
  • Same with me! In my opinion, this was caused because they switched to WPF. – cskwg Jan 21 '20 at 7:02
1

It's normally slow to open the first time after you start up your computer, but should get faster after that.

The reason is that it uses the .Net framework for some things, and that's probably the only .Net framework app you use on your machine. So the first time, all those assemblies (dlls) need to be loaded as well.

But this happens only once. From then on they're cached, and even if that cache is paged to disk the retrieval isn't too bad.

1

Have you applied a service pack to your instance and tools?

1
  • Yes, it's up to date. – Keng May 21 '09 at 13:31
1

This might work...

  1. Download the Certificate Revocation List from: http://crl.microsoft.com/pki/crl/products/CodeSignPCA.crl
  2. Create a path on a local web server for /pki/crl/products and put the CRL there.
  3. Create an entry on the hosts file (C:\Windows\System32\Drivers\etc) to put crl.microsoft.com to the IP address of that local web server.
2
1

change your SQL Server Management Studio shortcut to have the nosplash switch at the end. This will prevent the SSMS Splash window from appearing on loading, which reduces loading time a bit.

the default would be:

"C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\Ssms.exe" /nosplash
0

Here's what we did. Since our proxy server is a white-list only, we set the connection in IE to use the proxy which then send a failure back immediately rather than waiting upwards of 60 seconds.

2
  • what are you talking about dude? When did SSMS use a proxy server? WTF? I've never heard of this... – Pure.Krome May 21 '09 at 1:53
  • 2
    Proxy is set in IE. Therefore, by default, web based connections will go through that proxy. That includes by SSMS. – K. Brian Kelley May 21 '09 at 2:02
0

This won't be the final solution, but it sure helps: Edit the short cut for SQL Server Management Studio and add " /nosplash" to the end of the target field (without the quotes, of course).

That's assuming it is SSMS that is starting slowly. (edit: must be, just noticed the tag for it)

0

Another way to really speed up SSMS opening is right-click the shortcut for it, choose properties. Change the Target to this:

"C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\Ssms.exe" -nosplash

The change is the addition of the -nosplash flag at the end. This will speed you up quite a bit opening. I learned this trick at SQL Saturday.

0

I had this same problem. I found that Windows Defender was seeing ssms.exe as a threat. So i added an exclusion and it solved the problem. Windows Security -> Virus & threat protection settings -> Manage settings -> Add or Remove Exclusions..

Not the answer you're looking for? Browse other questions tagged or ask your own question.