0

I want to upgrade Apache to 2.4.46 or later on RHEL 7. One step in the instructions I'm following is to Enable the EPEL repository, like so...

cd /etc/yum.repos.d && wget http://mirror.centos.org/centos/7/os/x86_64/repodata/repomd.xml`rpm -q --qf "%{VERSION}" $(rpm -q --whatprovides redhat-release)`.repo

The mirror is not available, so I get a 404, but I also tried using other mirrors and I still get a 404 error. How do I enable the EPEL repo on RHEL 7?

0

1 Answer 1

1

That's a pretty nasty error in that tutorial. That entire step is wrong and should be skipped. For posterity, it says:

  1. Enable EPEL Repository

Run the following command to enable EPEL repository for CentOS 7. You can get all CentOS 7 repos at http://mirror.centos.org/centos/7/

# cd /etc/yum.repos.d && wget http://mirror.centos.org/centos/7/os/x86_64/repodata/repomd.xml`rpm -q --qf "%{VERSION}" $(rpm -q --whatprovides redhat-release)`.repo

The epel-release package ships with the repo already enabled, so it isn't clear what they were aiming at here. In any case, if you have already installed epel-release, then move on.


You can find accurate official instructions for installing EPEL at its home page.

6
  • Thank you. Though when I run yum install httpd the output says Package httpd-2.4.6-97.el17_9.x86_64 already installed and latest version. But in reality 2.4.46 is currently the latest.
    – arnoldbird
    Feb 10, 2021 at 17:54
  • I'll have a look at that EPEL link you posted. Answer may lie there. Update: I'm not getting anywhere with it. Not sure how to make the system recognize it doesn't have the latest Apache.
    – arnoldbird
    Feb 10, 2021 at 18:13
  • @arnoldbird That tutorial is to install the latest Apache version provided by your Linux distribution, not the latest Apache version published by the Apache foundation. Why are you trying to do that? Feb 10, 2021 at 18:34
  • A security scan is telling us we need to update to 2.4.46 or later.
    – arnoldbird
    Feb 10, 2021 at 18:36
  • @arnoldbird You do not. Feb 10, 2021 at 18:37

Not the answer you're looking for? Browse other questions tagged .