0

When attempting to create a GKE cluster via gcloud, web console, or pulumi I'm receiving the error: Google Compute Engine: Required 'compute.networks.get.

The permission for this account have Owner, Editor, and Compute Admin. Testing for compute.networks.get using the troubleshooter also shows that it is good.

Not sure why this is happening. It seemed to have been working fine the day before.

Thanks in advance.

Edit: I can also run gcloud compute regions describe us-east1 --project=myproj as well as the list command without issue so something is not adding up.

Edit 2: Full error is:

googleapi: Error 403: Retry budget exhausted (5 attempts): Google Compute Engine: Required 'compute.regions.get' permission for 'projects/myproj/regions/us-central1'., forbidden

1

It seems that the issue is with shared VPC. You need to allow the service accounts in the service project to use the sub-network with a binding resource. To do this:

Enable the permissions in the service account(s) to include 'roles/compute.networkUser' . This provides access to a shared VPC network.

I've found a similar issue on the terraform GitHub, and this is the workaround a user proposed.

Also you can disabling and then re-enabling both Compute API and Kubernetes API You could also check the following documentation: Enabling the Google Kubernetes Engine API in your projects

Additionally at this moment Google Kubernetes Engine is reporting issues: Incident began at 2021-02-19 05:47 (all times are US/Pacific). You can track the current status on https://status.cloud.google.com/ and for this particular error you could check https://status.cloud.google.com/incident/container-engine/21004

Description: We are experiencing an intermittent issue with Google Kubernetes Engine creation. Our engineering team continues to investigate the issue. We will provide an update by Friday, 2021-02-19 10:30 US/Pacific with current details.

1
  • > Also you can disabling and then re-enabling both Compute API and Kubernetes API You could also check the following documentation: Enabling the Google Kubernetes Engine API in your projects This worked! Looks like a service account was deleted. – Adgezaza Feb 19 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.