1

I'm trying to access a Windows Server 2019 share (inside a domain) from a CentOS6 host.

I can browse the share via smbclient, but mounting fails:

Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE CIFS VFS: Send error in SessSetup = -13 CIFS VFS: cifs_mount failed w/return code = -13

On the Windows side, it complain about the following (from the Event Viewer):

An account failed to log on.

Subject:
                Security ID:                            NULL SID
                Account Name:                     -
                Account Domain:                  -
                Logon ID:                               0x0

Logon Type:                                          3

Account For Which Logon Failed:
                Security ID:                            NULL SID
                Account Name:                    [USER]
                Account Domain:                  [DOMAIN]

Failure Information:
                Failure Reason:                      Unknown user name or bad password.
                Status:                                    0xC000006D
                Sub Status:                            0xC000006A

Process Information:
                Caller Process ID:  0x0
                Caller Process Name:           -

Network Information:
                Workstation Name:              \\[IP]
                Source Network Address:    [IP]
                Source Port:                          46041

Detailed Authentication Information:
                Logon Process:                     NtLmSsp 
                Authentication Package:     NTLM
                Transited Services:                -
                Package Name (NTLM only):              -
                Key Length:                           0

However, the credentials are absolutely correct - I've also tried creating a brand new user as well, with the same error.

I'm not really sure how to diagnose this - help would be greatly appreciated.

Thanks!

0

What version of samba do you have installed?
Query via rpm -qa | grep samba Make sure you have samba4 installed.

I am assuming the issue is related to version of SMB protocol the client is trying to use when connecting. SMB Version 1 is now disabled by default on Windows Server 2019. I would not recommend enabling it.

This is an example on adding debugging. Focus on the -d10 option.

smbclient -U user //10.0.0.20/shares password -d10
Note that to connect to a Windows 2012 server with encrypted transport selecting a max-protocol of SMB3 is required.
smbclient -m SMB3 -U user //10.0.0.20/shares password -d10

Find out what version of SMB your are running on the windows file server. SMBv1 is likely disabled by default
Run: Get-SmbServerConfiguration in powershell on the server.
This will give you the smb server information.

Run Get-SmbConnection in powershell to see the current connections on the server
PS C:\Windows\system32> Get-SmbConnection

PS C:\Windows\system32> Get-SmbConnection

ServerName ShareName UserName      Credential    Dialect NumOpens
---------- --------- --------      ----------    ------- --------
localhost  IPC$      TEST\bit      TEST\bit      3.1.1   0

Check out for troubleshooting information https://docs.microsoft.com/en-us/windows-server/storage/file-server/troubleshoot/detect-enable-and-disable-smbv1-v2-v3

Try cifs client
Check out about versions of SMB https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/storage_administration_guide/mounting_an_smb_share

1
  • Thank you for your detailed response! I'll give your suggestions a shot and report back. – dkd6 Feb 25 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.