1

I need the mpt2sas drivers to get Centos8 to work with my servers. Thanks to them using the rhel nutered kernel the device id's have been removed and wont load with out using a dd disk. I have both maas and openstack ironic/image service for openstack. In order to get those drivers back on the images that those 2 systems build/upload as far as I can tell I need either a custom vanilla rpm with the proper drivers or to find a way to get those build systems to pull the dd disk in during build time.

I am not sure which option would be more realistic to accomplish. maas has the ks boot dd option which i was not able to get to work when using packer-maas I haven't had much experience with packer or ks so it may be something I did wrong.

The other option I had no issues making the kernel but am at a loss on how to build the rpm of it as all the instructions I have found were from the 2.6 kernel era. I was expecting to have to use a local rpm repo to mirror the centos8 repo and make my vanilla kernel be listed as the latest of the kernel series.

Any suggestions on how to make this work would be greatly appreciated.

2 Answers 2

0

ELRepo provides many drivers for obsolete hardware that RHEL has removed from its kernels, as well as more recent longterm and mainline kernels (with such drivers already included).

2
  • I could have sworn i had tried the elrepo kmods before but after retrying the kmod again it worked. now to figure out how to include them with the scripting systems included.
    – Kendrick
    Mar 21, 2021 at 1:07
  • bonus it looks like the next release will add these drivers back in to rhel
    – Kendrick
    Jul 12, 2021 at 1:13
0

Now you'll find the drivers in this repo by the kernel modules SIG.

https://cbs.centos.org/koji/packageinfo?packageID=8521

I tried to find out if there's a way to load the driver disk or the single kmod from the rd.break initrd but things that don't follow the 'insert multi-gigabyte DVD image to load a 200KB driver' are just no longer properly documented.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .