0

On a MySQL 5.5.62 server, with InnoDB tables, I run mytop, and in the "qps now" field it reports something like 40-70. The historical qps is about 60.

I then hit "m" to see the qps value as each second passes, and the only number that pops up is "1". Never less than 1, never more than 1. Steady 1.

What is going on? Is this utilily reliable?

Should I perhaps drop it and rely on the "show status" of the server, getting the "Queries" value twice in a row, subtracting and dividing by the time that elapsed? When I do that, I get about 40-70, as the main dashboard mytop page indicates.

0

Where did you find mytop? That utility is ancient. The original mytop hasn't had an update since 2007, and while someone else tried to keep developing it for a while, even he appears to have given up, and his web site is dead. Linux distros such as Debian are finally beginning to drop it.

It was superseded by innotop many years ago.

2
  • I didn't do the searching. Yum did. As I wrote I'm using MySQL 5.5.62 so very likely it's meant to work OK with the mytop that Yum got for me. I have also installed innotop, so I guess I can use that too. Still I'd like to use mytop as well, as long as it's not giving me misleading stats. – GID Mar 1 at 18:35
  • @GID That seems unlikely. Mytop hasn't been updated for any MySQL version after early 4.x. I'm surprised you found it in your Linux distribution. – Michael Hampton Mar 1 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.