I have setup a posfix mailserver and some of the messages (sent from Microsoft exchange online) are rejected with below error.

SMTPSEND.BareLinefeedsAreIllegal; message contains bare linefeeds, which cannot be sent via DATA and receiving system does not support BDAT

I found a Miscrosoft forum that asked to enable ESMTP in receiveing server but I couldn't find a way of doing it. Or based on the above error is there a way to support BDAT in postfix servers?

Update: The output of the nc -C mx.xxxxxxx.com 25 <<<$'EHLO example.com\nQUIT\n'

220 localhost ESMTP Postfix
250-SIZE 1024000000
250 DSN
221 2.0.0 Bye
  • 1
    Have you had look on this? postfix.org/BDAT_README.html – Bogdan Stoica Mar 2 at 6:07
  • Yes, it says BDAT is enabled by default and can be disabled. But I haven't disabled it in my server so not sure what's the exact issue. – Yasitha Mar 2 at 7:03
  • 1
    Are you running postfix behind some sort of intercepting firewall? (edit your question to show your servers greeting, e.g. the output of the command nc -C mx.example.com 25 <<<$'EHLO example.com\nQUIT\n') – anx Mar 2 at 14:58
  • Added the output. – Yasitha Mar 5 at 3:15
  • 1
    It looks like you didn't actually connect to your server, or it is seriously misconfigured. Postfix answered as 'localhost', which should never happen. Check your server's hostname. – Michael Hampton Mar 5 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.