0

So I have Nginx running on ubuntu server inside proxmox VM, and it's redirecting traffic to my ghost blog, and when I use my local IP 10.0.0.143:80, it works fine, but when I try to access using my domain name, it redirects to /UI and displays a 403 HTTP error.

I have in Cloudflare SSL disabled because I want to make it work without SSL first and remove one more variable that could make this not work first try and an A record pointed to my public IP.

I also tried disabling my firewall in my router to see if that was the problem but no luck with that. Also, ports 80 and 443 are open in the router.

Also tried using my phone without being connected to the wifi, but no luck too.

DOMAIN NAME: zeusdevs.com

DNS CONFIG: enter image description here

netstat -plant output: enter image description here

Nginx Config:

server {
    listen 80 default_server;
    listen [::]:80 default_server;
    server_name zeusdevs.com;
    access_log /var/log/nginx/zeusdevs.log;

    location / {
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header Host $http_host;
        proxy_set_header X-NginX-Proxy true;

        proxy_pass http://10.0.0.143:8080;
        proxy_redirect off;
    }
}
3
  • Fixed. Restarted my router and it worked. Hate ISP routers so bad.
    – DeadSec
    Mar 10 '21 at 13:23
  • Still can't figure out why its redirecting to /ui
    – DeadSec
    Mar 10 '21 at 13:45
  • Reset cache and it fixed the /ui
    – DeadSec
    Mar 13 '21 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.