So we installed zammad a while ago and it always worked like charm until yesterday when we suddenly got a 404 at first and than (without touching anything) a 502. I’ve seen another Post on here which is resolved but any of the steps in that post didn’t help me anything at all.

Not sure, how can i find out? Used Zammad installation source: deb Operating system: Ubuntu 18.04 Browser + version: Any

Expected behavior: To work again like bevor

Actual behavior: A 502 Bad Gateway

Steps to reproduce the behavior: i don’t know

Error log from /var/log/nginx/zammad.error.log looks like this

2021/03/12 07:41:13 [error] 234787#234787: *17 connect() failed (111: Connection refused) while connecting to upstream, client:, server: support. solid.at, request: "GET / HTTP/1.1", upstream: "", host: " support.solid.at"

I already tried: Updated but only security updates, but zammad didn't work before that neither Restarting all service - worked and all are up an running - done with systemctl status zammad[tab][tab] and than systemctl status plus the service Now i came to an error where i can't start nginx if i run nginx -t i get the following which seams to me like a spelling error. But i can't seem to figure it out.

root@zammad:/etc/nginx/sites-available# nginx -t
nginx: [emerg] unknown directive "n /etc/nginx/sites-enabled/searchindex:rebuild:1
  • Please add output of nginx -T to the post. Mar 12, 2021 at 16:03
  • @TeroKilkanen the Output is at the bottom
    – OTRAY
    Mar 12, 2021 at 16:04
  • That is not nginx -T, notice the capital letter. Mar 12, 2021 at 16:16
  • Ok i get this when i run nginx -T
    – OTRAY
    Mar 15, 2021 at 6:08
  • [warn] 24959#24959: the "user" directive makes sense only if the master process runs with super-user privileges, ignored in /etc/nginx/nginx.conf:1 nginx: the configuration file /etc/nginx/nginx.conf syntax is ok 2021/03/15 06:08:04 [emerg] 24959#24959: open() "/run/nginx.pid" failed (13: Permission denied) nginx: configuration file /etc/nginx/nginx.conf test failed
    – OTRAY
    Mar 15, 2021 at 6:08

1 Answer 1


So what did work for me, is to set up a new VM, made a backup of the old zammad db. Imported that into the new VM and all did work like a charm. Thanks for your help :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.