1

I manage a FreeBSD server running usual AMP setup. Apache, Mysql, Php-fmp

Everything is working fine. In order to help out with speeding up a couple of Wordpress sites; we run php cli to run the wp_crontab.php regularly. This is running without issue; however, I am regularly getting emails with the following:

PHP Warning:  Missing arginfo for Imagick::__tostring() in Unknown on line 0
PHP Warning:  Missing arginfo for Imagick::getimagehistogram() in Unknown on line 0

Php8.0

Would like to fix; but if not, what is the best practice for disabling these emails?

I have tried using

error_reporting=0
error_reporting=E_ALL & ~E_NOTICE & ~E_Warning

And some other settings in hopes to suppress these warning until I figured out what library I need to fix.

So, 2 questions:

  1. how to disable warnings from php on the CLI?
  2. What are these 2 missing arginfo warnings and how could I possibly fix that?
1
  • To clarify. I am trying those settings in /usr/local/etc/php.ini Mar 12, 2021 at 18:06

1 Answer 1

0

Being unable to find and answer and finding a few articles of bugs specific to the 8.0 implementation when; I just returned to 7.4.16.

Cheers, T

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.